您的位置:首页 > 其它

poj 2507Crossed ladders 计算几何,二分

2014-03-15 12:25 561 查看
[align=left]Problem Description[/align]
A narrow street is lined with tall buildings. An x foot long ladder is rested at the base of the building on the right side of the street and leans on the building on the left side. A y foot long ladder
is rested at the base of the building on the left side of the street and leans on the building on the right side. The point where the two ladders cross is exactly c feet from the ground. How wide is the street?



[align=left]Input[/align]
Each line of input contains three positive floating point numbers giving the values of x, y, and c.

[align=left]Output[/align]
For each line of input, output one line with a floating point number giving the width of the street in feet, with three decimal digits in the fraction.

[align=left]Sample Input[/align]

30 40 10
12.619429 8.163332 3
10 10 3
10 10 1


[align=left]Sample Output[/align]

26.033
7.000
8.000
9.798


设两边高分别为h1、h2则h1=sqrt(x^2-c^2),h2=sqrt(y^2-c^2);设从交点到两边距离分别为s1/s2,由c/h1=s2/L,c/h2=s1/L;联立可得1/h1+1/h2=1/c,用勾股定理将h1/h2用L表示,将求得的c与所给的值比较。
#include <iostream>
#include <cstdio>
#include <cmath>
#define  end 0.0000001
using namespace std;
double x, y, c = 0;
double Fw(double w)
{
return sqrt((x*x - w*w)*(y*y-w*w)) / (sqrt(x*x-w*w)+ sqrt(y*y-w*w) ) - c;
}
int main()
{
while (scanf("%lf%lf%lf", &x, &y, &c)==3){
double mid = 0, up = 0, down = 0;
x < y ? up = y : up = x;
while (up -down > end){
mid = (up + down) / 2.0;
if (Fw(mid) > 0)
down = mid;
else
up = mid;
}
printf("%0.3f\n", mid);
}
return 0;
}
第一遍AC的代码:
#include<stdio.h>
#include<math.h>
#define enp 1e-10
double x,y,c;
double f(double a)
{
double b,d;
b=sqrt(x*x-a*a);
d=sqrt(y*y-a*a);
return b*d/(b+d)-c;
}
int main()
{
double mid,min,max;
while(~scanf("%lf%lf%lf",&x,&y,&c))
{
x>y?max=x:max=y;
mid=min=0;
while(max-min>enp)
{
mid=(max+min)/2.0;
if(f(mid)>0)
min=mid;
else
max=mid;
}
printf("%.3f\n",mid);//一定要用%f
}
return 0;
}



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: