您的位置:首页 > 其它

PAT 1012. The Best Rank (25)

2014-03-13 20:00 393 查看


1012. The Best Rank (25)

时间限制

400 ms

内存限制

32000 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing
on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:
StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91


Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student
ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output "N/A".
Sample Input
5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output
1 C
1 M
1 E
1 A
3 A
N/A


提交代码

结构体数组排序类。

内外层循环i,j到底哪个做下标看清楚!!!!3分与25分的差别啊。。。。

#include<stdio.h>
#include<string.h>
const int MAX=2014,INF=0x7fffffff;
struct E{
char id[10];
int a;  //Average 观察题目规律四舍五入
int c;  //C program
int m;	//Math
int e;	//English
int rank[4]; //A>C>M>E
int bestRank;  //最佳排名
char ch; //排名方式
}r[MAX];
char num2char(int x)
{
if(x==0)	return 'A';
if(x==1)	return 'C';
if(x==2)	return 'M';
if(x==3)	return 'E';
return '@';
}
int main()
{
//freopen("G:\\in.txt","r",stdin);

int i,j,n,m,num;
while(scanf("%d%d",&n,&m)!=EOF){
for(i=0;i<n;i++){
scanf("%s%d%d%d",r[i].id,&r[i].c,&r[i].m,&r[i].e);
r[i].rank[0]=r[i].rank[1]=1;
r[i].rank[2]=r[i].rank[3]=1;
int t1=(r[i].c+r[i].m+r[i].e)/3;    //四舍五入
float t2=(float)(r[i].c+r[i].m+r[i].e)/3;
if(t2-t1<0.5)
r[i].a=t1;
else
r[i].a=t1+1;
}
for(i=0;i<n;i++){
for(j=0;j<n;j++){
if(r[j].a>r[i].a)
r[i].rank[0]++;
}
}
for(i=0;i<n;i++){
for(j=0;j<n;j++){
if(r[j].c>r[i].c)
r[i].rank[1]++;
}
}
for(i=0;i<n;i++){
for(j=0;j<n;j++){
if(r[j].m>r[i].m)
r[i].rank[2]++;
}
}
for(i=0;i<n;i++){
for(j=0;j<n;j++){
if(r[j].e>r[i].e)
r[i].rank[3]++;
}
}
for(i=0;i<n;i++){     //计算最佳排名
int tmp=INF;
for(j=0;j<4;j++){
if(r[i].rank[j]<tmp){
tmp=r[i].rank[j];
num=j;
}
}
r[i].bestRank=tmp;
r[i].ch=num2char(num);
}
for(i=0;i<m;i++){
char str[10];
scanf("%s",str);
for(j=0;j<n;j++){
if(strcmp(str,r[j].id)==0){
printf("%d %c\n",r[j].bestRank,r[j].ch); //*********r[j]非r[i]!!!*******
break;
}
}
if(j==n)
printf("N/A\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: