您的位置:首页 > 理论基础 > 数据结构算法

数据结构--线段树--区间涂色问题

2014-03-07 19:58 246 查看
Count the Colors

Time Limit: 2 Seconds Memory Limit: 65536 KB

Painting some colored segments on a line, some previously painted segments may be covered by some the subsequent ones.
Your task is counting the segments of different colors you can see at last.

Input



The first line of each data set contains exactly one integer n, 1 <= n <= 8000, equal to the number of colored segments.
Each of the following n lines consists of exactly 3 nonnegative integers separated by single spaces:

x1 x2 c

x1 and x2 indicate the left endpoint and right endpoint of the segment, c indicates the color of the segment.
All the numbers are in the range [0, 8000], and they are all integers.
Input may contain several data set, process to the end of file.

Output

Each line of the output should contain a color index that can be seen from the top, following the count of the segments of this color, they should be printed according to the color index.
If some color can't be seen, you shouldn't print it.
Print a blank line after every dataset.

Sample Input

5

0 4 4

0 3 1

3 4 2

0 2 2

0 2 3

4

0 1 1

3 4 1

1 3 2

1 3 1

6

0 1 0

1 2 1

2 3 1

1 2 0

2 3 0

1 2 1

Sample Output

1 1

2 1

3 1
1 1
0 2

1 1

线段树的典型应用

#include "cstdio"  //zju 1610  线段树简单应用
#include "cstring"
#include "iostream"
using namespace std;

#define N 8005
const int NoColor = -1; //无颜色标记
const int MulColor = -2; //混合色标记

struct node
{
int l,r;
int col;
}Tree[4*N];

int a
,many
; //a[]用于记录颜色,many[]统计颜色出现次数

void Build(int t,int l,int r)  //建树
{
Tree[t].l = l;
Tree[t].r = r;
Tree[t].col = NoColor;  //初始化全部变为无色
if(Tree[t].l+1==Tree[t].r)
return ;
int mid = (Tree[t].l + Tree[t].r)/2;
Build(t<<1,l,mid);
Build(t<<1|1,mid,r);
}

void Update(int t,int l,int r,int k)
{
if(Tree[t].col == k)    //颜色相同,不用继续考虑
return ;
if(Tree[t].l==l && Tree[t].r==r)    //以当前节点为根节点的子树全部在线段内,直接改变根节点颜色值,return ;
{  Tree[t].col = k;    return ; }
if(Tree[t].l+1==Tree[t].r)  //到达最底层,更新线段颜色值,return ;
{    Tree[t].col = k; return ; }
if(Tree[t].col != MulColor)  //当前颜色值不为混合色,将颜色值向下推一层;
{
Tree[t<<1].col   = Tree[t].col;
Tree[t<<1|1].col = Tree[t].col;
}
Tree[t].col = MulColor;  //节点颜色改变
int mid = (Tree[t].l+Tree[t].r)/2;
if(r<=mid)
Update(t<<1,l,r,k);
else if(l>=mid)
Update(t<<1|1,l,r,k);
else
{
Update(t<<1,l,mid,k);
Update(t<<1|1,mid,r,k);
}
}

void Stats(int t)   //统计每一节点的颜色状态
{
int i,j;
if(Tree[t].l+1==Tree[t].r)
{
a[Tree[t].l] = Tree[t].col;
return ;
}
if(Tree[t].col>=0)
{
for(i=Tree[t].l; i<Tree[t].r; ++i)
a[i] = Tree[t].col;
return ;
}
Stats(t<<1);
Stats(t<<1|1);
}

int main()
{
int n;
int i,j;
int x,y,k;
while(scanf("%d",&n)!=-1)
{
Build(1,1,N); //建树
while(n--)
{
scanf("%d %d %d",&x,&y,&k);
x++; y++;
Update(1,x,y,k);  //加入新添加的线段,更新树的颜色值
}
memset(a,0,sizeof(a));
memset(many,0,sizeof(many));
Stats(1);
int t = -1;

for(i=1; i<=8000; ++i)
{
if(a[i]==t) continue;
t = a[i];
if(t!=-1)
many[t]++;
}
for(i=0; i<=8000; ++i)
{
if(many[i])
printf("%d %d\n",i,many[i]);
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  数据结构