您的位置:首页 > 其它

浙大 pat Basic Level 1004

2014-02-28 09:54 225 查看

1004. 成绩排名 (20)

读入n名学生的姓名、学号、成绩,分别输出成绩最高和成绩最低学生的姓名和学号。

输入格式:每个测试输入包含1个测试用例,格式为

第1行:正整数n
第2行:第1个学生的姓名 学号 成绩
第3行:第2个学生的姓名 学号 成绩
... ... ...
第n+1行:第n个学生的姓名 学号 成绩

其中姓名和学号均为不超过10个字符的字符串,成绩为0到100之间的一个整数,这里保证在一组测试用例中没有两个学生的成绩是相同的。

输出格式:对每个测试用例输出2行,第1行是成绩最高学生的姓名和学号,第2行是成绩最低学生的姓名和学号,字符串间有1空格。

输入样例:
3
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95

输出样例:
Mike CS991301
Joe Math990112



#include <iostream>
#include <vector>
#include <string>
using namespace std;
int main()
{
vector<string> name;
vector<string> index;
vector<int> score;
int num;
vector<int>::size_type highscore = 0, lowscore = 0;
cin >> num;
for(int i = 0; i != num; i++)
{
string tempname,tempindex;
int tempscore;
cin >> tempname >> tempindex >> tempscore;
name.push_back(tempname);
index.push_back(tempindex);
score.push_back(tempscore);
}
for(vector<int>::size_type i=0; i != score.size(); i++)
{
if(score[i] > score[highscore])
highscore = i;
if(score[i] < score[lowscore])
lowscore = i;
}
cout << name[highscore] << ' ' << index[highscore] << endl;
cout << name[lowscore] << ' ' << index[lowscore] <<endl;
system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: