您的位置:首页 > 其它

2056——Rectangles

2014-02-26 22:09 295 查看
Problem Description

Given two rectangles and the coordinates of two points on the diagonals of each rectangle,you have to calculate the area of the intersected part of two rectangles. its sides are parallel to OX and OY .

 

Input

Input The first line of input is 8 positive numbers which indicate the coordinates of four points that must be on each diagonal.The 8 numbers are x1,y1,x2,y2,x3,y3,x4,y4.That means the two points on the first rectangle are(x1,y1),(x2,y2);the other two points
on the second rectangle are (x3,y3),(x4,y4).

 

Output

Output For each case output the area of their intersected part in a single line.accurate up to 2 decimal places.

 

Sample Input

1.00 1.00 3.00 3.00 2.00 2.00 4.00 4.00
5.00 5.00 13.00 13.00 4.00 4.00 12.50 12.50

 

Sample Output

1.00
56.25

 

#include <stdio.h>
void swap(float *a, float *b)
{
if(*a > *b)
{
float t=*a;
*a=*b;
*b=t;
}
}
main()
{
float x1,y1,x2,y2;
float x3,y3,x4,y4;
float xd,xu,yd,yu;
while(scanf("%f%f%f%f%f%f%f%f",&x1,&y1,&x2,&y2,&x3,&y3,&x4,&y4)!=EOF)
{
if(x1>x2) swap(&x1,&x2);
if(y1>y2) swap(&y1,&y2);
if(x3>x4) swap(&x3,&x4);
if(y3>y4) swap(&y3,&y4);
xd=x1>x3?x1:x3;
yd=y1>y3?y1:y3;
xu=x2>x4?x4:x2;
yu=y2>y4?y4:y2;
if(xu<xd || yu<yd)
printf("0.00\n");
else
printf("%.2f\n",(xu-xd)*(yu-yd));
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  基础题