您的位置:首页 > 其它

hdu2509Be the Winner (尼姆博弈,注意全为1的情况)

2014-02-25 18:09 337 查看
Problem Description
Let's consider m apples divided into n groups. Each group contains no more than 100 apples, arranged in a line. You can take any number of consecutive apples at one time.

For example "@@@" can be turned into "@@" or "@" or "@ @"(two piles). two people get apples one after another and the one who takes the last is

the loser. Fra wants to know in which situations he can win by playing strategies (that is, no matter what action the rival takes, fra will win).

Input
You will be given several cases. Each test case begins with a single number n (1 <= n <= 100), followed by a line with n numbers, the number of apples in each pile. There is a blank line between cases.

Output
If a winning strategies can be found, print a single line with "Yes", otherwise print "No".

Sample Input
2
2 2
1
3


Sample Output
No
Yes[code]#include<stdio.h>
int main()
{
int n,a,c,t;
while(scanf("%d",&n)==1)
{
  c=0;t=0;
for(int i=0;i<n;i++)
{
scanf("%d",&a); c^=a; if(a>1) t=1;
}
printf("%s\n",(c!=0&&t||c==0&&t==0)?"Yes":"No");
}
}


[/code]


                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: