您的位置:首页 > 产品设计 > UI/UE

Ubiquitous Religions

2014-02-25 17:40 429 查看
Description

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask
m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound
of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The
end of input is specified by a line in which n = m = 0.

Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

Sample Input

10 9

1 2

1 3

1 4

1 5

1 6

1 7

1 8

1 9

1 10

10 4

2 3

4 5

4 8

5 8

0 0

Sample Output

Case 1: 1

Case 2: 7

参考代码:

#include<stdio.h>
int pre[50010],num[50010],r;
void get()
{
int i;
for(i=1;i<50010;i++)
{
pre[i]=i;
num[i]=1;
}
}
int find(int x)
{
while(x!=pre[x])
x=pre[x];
return x;
}
void merge(int x,int y)
{
int fx=find(x);
int fy=find(y);
if(fx==fy)
return;
if(fx>fy)
{
r=fx;
fx=fy;
fy=r;
}
pre[fx]=fy;
num[fy]+=num[fx];
}
int main()
{
int i,j,m,n,x,y,t=1;
while(scanf("%d%d",&n,&m),n||m)
{
get();
for(i=1;i<=m;i++)
{
scanf("%d%d",&x,&y);
merge(x,y);
}
int s=num[find(1)],k=1;
for(i=2;i<=n;i++)
{
if(find(1)!=find(i))
{
s+=num[find(i)];
k++;
merge(1,i);
}
}
printf("Case %d: %d\n",t++,k+n-s);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: