您的位置:首页 > 其它

题目1464:Hello World for U

2014-02-23 21:25 309 查看
题目描述:

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h    d

e     l

l      r

lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And
more, we would like U to be as squared as possible -- that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.

输入:

There are multiple test cases.Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

输出:

For each test case, print the input string in the shape of U as specified in the description.

样例输入:
helloworld!
ac.jobdu.com


样例输出:
h   !
e   d
l   l
lowor
a    m
c    o
.    c
jobdu.


#include <iostream>

using namespace std;

int main()
{
string str;
while(cin>>str)
{
int N = 0,n1=0,n2=0;
N = str.size()+2;
n1 =int(N/3);
n2 = N-n1-n1;
for(int i=0;i<n1-1;i++)
{
cout<<str[i];
for(int j=1;j<=n2-2;j++)
cout<<" ";
cout<<str[N-2-1-i];
cout<<endl;
}
for(int i=n1-1;i<n1-1+n2;i++)
cout<<str[i];
cout<<endl;
}

return 0;
}

/**************************************************************
Problem: 1464
User: 小燧石
Language: C++
Result: Accepted
Time:10 ms
Memory:1520 kb
****************************************************************/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: