您的位置:首页 > 其它

As Easy As A+B

2014-02-22 00:41 246 查看

Problem Description

These days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. Of course, I got it after many waking nights. Give you some integers, your task is to sort these number ascending (升序). You should know how easy the problem is now! Good luck!

Input

Input contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted) and then N integers follow in the same line. It is guarantied that all integers are in the range of 32-int.

Output

For each case, print the sorting result, and one line one case.

Sample Input

2
3 2 1 3
9 1 4 7 2 5 8 3 6 9


Sample Output

1 2 3
1 2 3 4 5 6 7 8 9


#include<stdio.h>
int main()
{
int t,test,i,j,a[1000];
scanf("%d",&test);
while(test--)
{
scanf("%d",&t);
for(i=0;i<t;i++)
{
scanf("%d",&a[i]);
}
for(i=0;i<t-1;i++)
for(j=1;j<t;j++)
if(a[j]<a[j-1])
{
int k=a[j];
a[j]=a[j-1];
a[j-1]=k;
}
for(i=0;i<t-1;i++)
{
printf("%d ",a[i]);
}
printf("%d\n",a[t-1]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: