您的位置:首页 > 运维架构

OpenJudge/Poj 1207 The 3n + 1 problem

2014-02-15 22:14 381 查看
1.链接地址:
http://bailian.openjudge.cn/practice/1207/ http://poj.org/problem?id=1207
2.题目:

总时间限制:1000ms内存限制:65536kB描述Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs.
Consider the following algorithm:

1. 		 input n

2. 		 print n

3. 		 if n = 1 then STOP

4. 		 		 if n is odd then   n <-- 3n+1

5. 		 		 else   n <-- n/2

6. 		 GOTO 2


Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1

It
is conjectured that the algorithm above will terminate (when a 1 is
printed) for any integral input value. Despite the simplicity of the
algorithm, it is unknown whether this conjecture is true. It has been
verified, however, for all integers n such that 0 < n < 1,000,000
(and, in fact, for many more numbers than this.)

Given an input
n, it is possible to determine the number of numbers printed before the 1
is printed. For a given n this is called the cycle-length of n. In the
example above, the cycle length of 22 is 16.

For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j.

输入The input will consist of a series of pairs of integers i and j,
one pair of integers per line. All integers will be less than 10,000 and
greater than 0.

You should process all pairs of integers and
for each pair determine the maximum cycle length over all integers
between and including i and j. 输出For each pair of input integers i and j you should output i, j,
and the maximum cycle length for integers between and including i and j.
These three numbers should be separated by at least one space with all
three numbers on one line and with one line of output for each line of
input. The integers i and j must appear in the output in the same order
in which they appeared in the input and should be followed by the
maximum cycle length (on the same line). 样例输入
1 10
100 200
201 210
900 1000

样例输出
1 10 20
100 200 125
201 210 89
900 1000 174

来源Duke Internet Programming Contest 1990,uva 100

3.思路:

4.代码:

#include "stdio.h"
//#include "stdlib.h"
#define N 1000002
int a
;
int main()
{
int i,j,k,count,n,max,tmp;
while(scanf("%d%d",&i,&j) != EOF)
{
max=0;
//if(j<i){tmp=j;j=i;i=tmp;}
if(i<j)
{
max=0;
for(k=i;k<=j;k++)
{
if(a[k]>0) count = a[k];
else
{

count=1;
n=k;
while(n!=1)
{
if(n%2==0) n=n/2;
else n=3*n+1;
count++;
}
}
if(count>max) max=count;
}
}
else
{
for(k=j;k<=i;k++)
{
if(a[k] > 0) count = a[k];
else
{

count=1;
n=k;
while(n!=1)
{
if(n%2==0) n=n/2;
else n=3*n+1;
count++;
}
a[k] = count;
}

if(count>max) max=count;
}
}
printf("%d %d %d\n",i,j,max);
}
//system("pause");
return 1;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: