您的位置:首页 > 其它

Power Strings

2014-02-11 19:25 218 查看

Power Strings

Time Limit: 1000MS Memory limit: 65536K

题目描述

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation
by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).



输入

 Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A
line containing a period follows the last test case.

输出

 For each s you should print the largest n such that s = a^n for some string a.

示例输入

abcd
aaaa
ababab
.


示例输出

1
4
3

#include<stdio.h>
#include <string.h>
#include <math.h>
char s1[1100000];
int next[1100000],dp[1100000];
int main()
{
    int i,j,n,m,s,t,l;
    while(gets(s1))
    {
        if(strcmp(s1,".")==0)
            break;
        l=strlen(s1);
        next[0]=-1;
        next[1]=0;
        for(i=2,j=0;i<=l;)
        {
            if(j==-1||s1[i-1]==s1[j])
            {
                i++;j++;
                next[i-1]=j;
            }
            else
                j=next[j];
        }
        dp[0]=0;
        for(i=2;i<=l;i++)
        {
           n=next[i];
           if(n+n==i)
           {
               dp[i-1]=n;
           }else if(n+n<i)
           {
               dp[i-1]=0;
           }else
           {
               dp[i-1]=dp[n-1];
           }
        }
        if(dp[l-1]==0)
        {
            printf("1\n");
        }else
        {
            printf("%d\n",l/dp[l-1]);
        }
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: