您的位置:首页 > 其它

1028. List Sorting (25)

2014-01-25 23:19 99 查看
Excel can sort records according to any column. Now you are supposed to imitate this function.

Input

Each input file contains one test case. For each case, the first line contains two integers N (<=100000) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record
of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the
records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.

Sample Input 1
3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1
000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2
4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2
000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3
4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3
000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

此题的关键是用C++的流来完成输入时最后一个测试点会通不过 改用scanf 和 printf函数来完成!

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>
using namespace std;

struct Stu{
int id;
char name[20];
int grade;
};
bool compare1(Stu a,Stu b){
return a.id<b.id;
}
bool compare2(Stu a,Stu b){
if(strcmp(a.name,b.name)!=0)
return strcmp(a.name,b.name)<0;
else
return a.id<b.id;
}
bool compare3(Stu a,Stu b){
if(a.grade!=b.grade)
return a.grade<b.grade;
else
return a.id<b.id;
}
int main()
{
int N,C;
cin>>N>>C;
Stu *arr = new Stu
;
for(int i=0;i<N;i++){
scanf("%d%s%d",&arr[i].id,arr[i].name,&arr[i].grade);
}
if(C==1){
sort(arr,arr+N,compare1);
}
if(C==2){
sort(arr,arr+N,compare2);
}
if(C==3){
sort(arr,arr+N,compare3);
}
for(int i=0;i<N;i++){
printf("%06d %s %d\n", arr[i].id, arr[i].name, arr[i].grade);
}
return 0;
}


[/code]

                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: