您的位置:首页 > 产品设计 > UI/UE

POJ-1503-Integer Inquiry-2013-11-25 23:15:45

2014-01-11 21:53 225 查看
Integer Inquiry

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 27942 Accepted: 10859
Description

One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers. 

``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.) 

Input

The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative). 

The final input line will contain a single zero on a line by itself. 

Output

Your program should output the sum of the VeryLongIntegers given in the input.
Sample Input
123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0

Sample Output
370370367037037036703703703670

Source

East Central North America 1996

# include<stdio.h>
# include<string.h>

int main()
{
char num[110];
int num1[110],sum[110],len,i,j;
memset(num,0,sizeof(num));
memset(sum,0,sizeof(sum));
memset(num1,0,sizeof(num1));
while(scanf("%s",num) && strcmp("0",num)!=0)
{
len = strlen(num);
j = 0;
for(i=len-1;i>=0;i--)
num1[j++] = num[i] - '0';
for(i=0;i<105;i++)
{
sum[i] = num1[i] + sum[i];
if(sum[i]>=10)
{
sum[i]-=10;
num1[i+1]++;
}
}
memset(num1,0,sizeof(num1));
memset(num,0,sizeof(num));
}
for(i=104;i>=0;i--)
if(sum[i]!=0)
break;
for(;i>=0;i--)
printf("%d",sum[i]);
printf("\n");

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: