您的位置:首页 > 产品设计 > UI/UE

The Collatz Sequence

2013-12-07 17:34 204 查看
An algorithm given by Lothar Collatz produces sequences of integers, and is described as follows:

Step 1:Choose an arbitrary positive integer A as the first item in the sequence.
Step 2:If A = 1 then stop. Step 3:If A is even, then replace A by A / 2 and go to step 2.
Step 4:If A is odd, then replace A by 3 * A + 1 and go to step 2.
It has been shown that this algorithm will always stop (in step 2) for initial values of
A as large as 109, but some values of A encountered in the sequence may exceed the size of an integer on many computers. In this problem we want to determine the length of the sequence that includes all values produced until either
the algorithm stops (in step 2), or a value larger than some specified limit would be produced (in step 4).

Input 

The input for this problem consists of multiple test cases. For each case, the input contains a single line with two positive integers, the first giving the initial value of
A (for step 1) and the second giving L, the limiting value for terms in the sequence. Neither of these,
A or L, is larger than 2,147,483,647 (the largest value that can be stored in a 32-bit signed integer). The initial value of
A is always less than L. A line that contains two negative integers follows the last case.

Output 

For each input case display the case number (sequentially numbered starting with 1), a colon, the initial value for
A, the limiting value L, and the number of terms computed.

Sample Input 

3 100
34 100
75 250
27 2147483647
101 304
101 303
-1 -1


Sample Output 

Case 1: A = 3, limit = 100, number of terms = 8
Case 2: A = 34, limit = 100, number of terms = 14
Case 3: A = 75, limit = 250, number of terms = 3
Case 4: A = 27, limit = 2147483647, number of terms = 112
Case 5: A = 101, limit = 304, number of terms = 26
Case 6: A = 101, limit = 303, number of terms = 1

 

 

 

#include <stdio.h>

int main()
{
long i,j,k,a,l,terms,x;
i = 0;

while(scanf("%ld %ld",&a,&l),a >= 0 || l >= 0)
{
i++;
if(a == l)
break;
terms = 0;
x = a;
while(x!=1 && x<=l)
{
if(x%2 == 1)
x = 3*x+1;
else
x = x/2;
if(x == 1)
terms++;
terms++;
}
printf("Case %ld: A = %ld, limit = %ld, number of terms = %ld\n",i,a,l,terms);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: