您的位置:首页 > 其它

Zeros and Ones

2013-11-23 23:28 225 查看


题目描述

Consider strings of characters made up by concatenating any number of the strings 0, 01 or 11.

For example 00011111 is one such string, as is 001011, but 1011 is not. Your job is simply to determine if a given string can be constructed in this manner.

输入

There will be multiple problem sets. Input for each problem will be on one line. Each line (except

the last) will be of the form

n s

where n is a non-negative integer no larger than 100 and s is a string of 0’s and 1’s of length n.

A value of n = 0 indicates end of input.

输出

Each problem should generate one line of code, either,

String m can be generated.

or

String m can not be generated.

accordingly, where m is the number of the problem (stating at 1).

样例输入

8 00011111

6 001011

4 1011

0

样例输出

String 1 can be generated.

String 2 can be generated.

String 3 can not be generated.

题目意思是输入一个由0,1组成的字符串检测其是否能由0,01,11这几个字符串构成。
规律就是只有是奇数个1开头的字符串不符合题意。源代码如下:

#include<iostream>
using namespace std;
int main()
{
int n,j=1,i;
char s[102];
while(cin>>n&&n)
{
for(i=0;i<n;i++)
cin>>s[i];
for(i=0;s[i]=='1'&&i<n;i++);
if(i%2)
cout<<"String "<<j<<" can not be generated."<<endl;
else cout<<"String "<<j<<" can be generated."<<endl;
j++;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: