您的位置:首页 > 其它

【PAT】1024. Palindromic Number 回文反转相加

2013-11-22 22:42 295 查看


1024. Palindromic Number (25)

时间限制

400 ms

内存限制

32000 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives
a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (<= 1010) is the initial numer and K (<= 100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output
the number obtained at the Kth step and K instead.
Sample Input 1:
67 3

Sample Output 1:
484
2

Sample Input 2:
69 3

Sample Output 2:
1353
3


题意:回文字,对输入数值进行判断,若不是回文,则反转相加继续。

分析:数值10^10,再迭代相加100次,大概达到10^40级;long long型也不足以表示,需要使用字符型处理。使用字符串的reverse处理。

代码:

#include <iostream>
#include <string>
#include <algorithm>			//reverse函数
using namespace std;

string add(string s,string rev)
{
string res="";
int k = s.size();
int sum,carry=0;
int i;
for(i=k-1;i>=0;i--)
{
sum = s[i]+rev[i]-'0'-'0'+carry;
res.insert(res.begin(),sum%10+'0');
carry = sum/10;
}
if(carry)res.insert(res.begin(),carry+'0');
return res;
}

bool isPalindromic(string& s,string& rev)
{
rev = s;
reverse(rev.begin(),rev.end());			//原字符串反转
if(s==rev) return true;
s = add(s,rev);
return false;
}

int main()
{
string s,rev;
int k;
cin>>s>>k;
int i;
for(i=0;i<k;i++)
{
if(isPalindromic(s,rev))
{
break;
}
}
cout<<s<<endl<<i<<endl;
system("PAUSE");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: