您的位置:首页 > 其它

POJ1936——All in All

2013-11-13 15:47 204 查看
Description

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into
the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.

Input

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.
Output

For each test case output "Yes", if s is a subsequence of t,otherwise output "No".
Sample Input
sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output
Yes
No
Yes
No


题意大致要求是两个串、 判断第一个串是否为第二个串的子串(不需要连续)。

#include<iostream>
#include<string.h>
#include<stdio.h>
#include<ctype.h>
#include<algorithm>
#include<stack>
#include<queue>
#include<set>
#include<math.h>
#include<vector>
#include<map>
#include<deque>
#include<list>
#define N 99999
using namespace std;
char a
,b
;
int main()
{
    while(scanf("%s%s",a,b)!=EOF)
    {
        int la=strlen(a);
        int lb=strlen(b);
        int j=0;
        int k=0;
        for(int i=0; i<strlen(b); i++)
            if(a[j]==b[i])
            {
                k++;
                j++;
            }
        if(k==strlen(a))
            puts("Yes");
        else
            puts("No");
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: