您的位置:首页 > 其它

UVa 10020 Minimal coverage (贪心&区间覆盖)

2013-10-29 19:28 423 查看

10020 - Minimal coverage

Time limit: 3.000 seconds

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=113&page=show_problem&problem=961

The Problem

Given several segments of line (int the X axis) with coordinates [Li,Ri]. You are to choose the minimal amount of them, such they would completely cover the segment [0,M].

The Input

The first line is the number of test cases, followed by a blank line.

Each test case in the input should contains an integer M(1<=M<=5000), followed by pairs "Li Ri"(|Li|, |Ri|<=50000, i<=100000), each on a separate line. Each test case of input is terminated by pair "0 0".

Each test case will be separated by a single line.

The Output

For each test case, in the first line of output your programm should print the minimal number of line segments which can cover segment [0,M]. In the following lines, the coordinates of segments, sorted by their left end (Li), should be printed
in the same format as in the input. Pair "0 0" should not be printed. If [0,M] can not be covered by given line segments, your programm should print "0"(without quotes).

Print a blank line between the outputs for two consecutive test cases.

Sample Input

2

1
-1 0
-5 -3
2 5
0 0

1
-1 0
0 1
0 0


Sample Output

0

1
0 1


《入门经典》P154上的经典贪心。

注意,题目的数据有缺陷,即使你不加 if (nowL < M) cnt = 0; 这一句也能AC。

完整代码:

/*0.065s*/

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N = 100005;

struct seg
{
	int l, r;
	bool operator < (const seg a) const
	{
		return l < a.l;
	}
} p
, ans
;

int main()
{
	int T, n, M, i, nowL, maxR, cnt, templ, tempr;
	bool found;
	scanf("%d", &T);
	while (T--)
	{
		scanf("%d", &M);
		n = 0;
		while (scanf("%d%d", &templ, &tempr), templ || tempr)
            if (templ < M && tempr) p[n++] = (seg){templ, tempr};///根本不能用的区间就不存进去了
        sort(p, p + n);
		for (i = nowL = cnt = 0; nowL < M; ++cnt)
		{
			found = false;
			maxR = 0;
			for (; i < n && p[i].l <= nowL; ++i)
				if (p[i].r > maxR)
				{
					found = true;
					maxR = p[i].r;///在区间左端点符合要求的情况下所能覆盖到的最右端
					ans[cnt] = p[i];
				}
			if (!found) break;
			nowL = maxR;///更新左端点
		}
		if (nowL < M) cnt = 0;///任务失败~
		printf("%d\n", cnt);
		for (i = 0; i < cnt; i++)
			printf("%d %d\n", ans[i].l, ans[i].r);
		if (T) putchar(10);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: