您的位置:首页 > 其它

POJ 3249 Test for Job DAG图上的单源最短路径

2013-10-24 11:16 309 查看
点击打开链接

Test for Job

Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 8584 Accepted: 1908
Description

Mr.Dog was fired by his company. In order to support his family, he must find a new job as soon as possible. Nowadays, It's hard to have a job, since there are swelling numbers of the unemployed. So some companies often use hard tests for their recruitment.

The test is like this: starting from a source-city, you may pass through some directed roads to reach another city. Each time you reach a city, you can earn some profit or pay some fee, Let this process continue until you reach a target-city. The boss will
compute the expense you spent for your trip and the profit you have just obtained. Finally, he will decide whether you can be hired.

In order to get the job, Mr.Dog managed to obtain the knowledge of the net profit Vi of all cities he may reach (a negative Vi indicates that money is spent rather than gained) and the connection between cities. A
city with no roads leading to it is a source-city and a city with no roads leading to other cities is a target-city. The mission of Mr.Dog is to start from a source-city and choose a route leading to a target-city through which he can get the maximum profit.

Input

The input file includes several test cases. 

The first line of each test case contains 2 integers n and m(1 ≤ n ≤ 100000, 0 ≤ m ≤ 1000000) indicating the number of cities and roads. 

The next n lines each contain a single integer. The ith line describes the net profit of the city i, Vi (0 ≤ |Vi| ≤ 20000) 

The next m lines each contain two integers x, y indicating that there is a road leads from city x to city y. It is guaranteed that each road appears exactly once, and there is no way to return to a previous city. 

Output

The output file contains one line for each test cases, in which contains an integer indicating the maximum profit Dog is able to obtain (or the minimum expenditure to spend)

Sample Input
6 5
1
2
2
3
3
4
1 2
1 3
2 4
3 4
5 6


Sample Output
7


Hint



Source

POJ Monthly--2007.07.08, 落叶飞雪

题意是说有n个点,m条边,并且每个点都有一个权值,让你求入度为0的点到出度为0的点的最大权值。
有很多种解法,我写了两种,一种是直接求最大权值,另一种是将每个点的权值为负,求出最小权值,最后输出负的。
两种方法基本原理都是一样的。
直接求最大权值:
#include<stdio.h>
#include<string.h>
#include<queue>
#define M  200007
#define inf 0x3f3f3f
using namespace std;
int head[M],in[M],val[M],dis[M],vis[M];
int n,m,cnt;
queue<int>q;
struct E
{
int to,next;
}edg[M*20];

void init()
{
for(int i=0;i<=n;i++)
{
head[i]=-1;
in[i]=vis[i]=0;
dis[i]=-inf;
}
cnt=0;
}

void addedge(int u,int v)
{
edg[cnt].to=v;
edg[cnt].next=head[u];
head[u]=cnt++;
}

int main()
{
while(scanf("%d%d",&n,&m)!=EOF)
{
init();
int a,b,c;
for(int i=1;i<=n;i++)
{
scanf("%d",&c);
val[i]=c;
}
for(int i=1;i<=m;i++)
{
scanf("%d%d",&a,&b);
addedge(b,a);
in[a]=1;
}
for(int i=1;i<=n;i++)
{
if(in[i]==0)
{
dis[i]=val[i];
vis[i]=1;
q.push(i);
}
}
while(!q.empty())
{
int t=q.front();
q.pop();
vis[t]=0;
for(int u=head[t];u!=-1;u=edg[u].next)
{
int v=edg[u].to;
if(dis[v]<dis[t]+val[v])
{
dis[v]=dis[t]+val[v];
if(!vis[v])
{
q.push(v);
vis[v]=1;
}
}
}
}
int maxx=-inf;
for(int i=1;i<=n;i++)
{
if(head[i]==-1&&dis[i]>maxx)
maxx=dis[i];
}
printf("%d\n",maxx);
}
return 0;
}


间接求最大权值:

#include<stdio.h>
#include<string.h>
#include<queue>
#define M  200007
#define inf 0x3f3f3f
using namespace std;
int head[M],in[M],val[M],dis[M],vis[M];
int n,m,cnt;
queue<int>q;
struct E
{
int to,next;
}edg[M*20];

void init()
{
for(int i=0;i<=n;i++)
{
head[i]=-1;
in[i]=vis[i]=0;
dis[i]=inf;
}
cnt=0;
}

void addedge(int u,int v)
{
edg[cnt].to=v;
edg[cnt].next=head[u];
head[u]=cnt++;
}

int main()
{
while(scanf("%d%d",&n,&m)!=EOF)
{
init();
int a,b,c;
for(int i=1;i<=n;i++)
{
scanf("%d",&c);
val[i]=-c;
}
for(int i=1;i<=m;i++)
{
scanf("%d%d",&a,&b);
addedge(b,a);
in[a]=1;
}
for(int i=1;i<=n;i++)
{
if(in[i]==0)
{
dis[i]=val[i];
vis[i]=1;
q.push(i);
}
}
while(!q.empty())
{
int t=q.front();
q.pop();
vis[t]=0;
for(int u=head[t];u!=-1;u=edg[u].next)
{
int v=edg[u].to;
if(dis[v]>dis[t]+val[v])
{
dis[v]=dis[t]+val[v];
if(!vis[v])
{
q.push(v);
vis[v]=1;
}
}
}
}
int maxx=inf;
for(int i=1;i<=n;i++)
{
if(head[i]==-1&&dis[i]<maxx)
maxx=dis[i];
}
printf("%d\n",-maxx);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: