您的位置:首页 > 其它

Poj 3461 Oulipo(KMP算法)

2013-10-17 21:37 381 查看
Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination,
l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program
that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T,
count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).

One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output
1
3
0


 

题意是:先输入一个n代表数据的个数,然后每组数据都有两个字符串A和B,求B中一共存在多少个A。

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;

char s[10010],e[1000010];
int next[1000010];
void getnext(char *s,int *next,int len)
{
int i,j;
next[0]=-1;
i=0;
j=-1;
while(i<len)
{
if(j==-1||s[j]==s[i])
{
i++;
j++;
next[i]=j;
}
else
j=next[j];
}
}
int kmp(char *e,char *s)
{
int i,j,k;
int L1,L2;
i=j=k=0;
L1=strlen(e);
L2=strlen(s);
getnext(s,next,L2);
while(i<L1)
{
if(e[i]==s[j])
{  i++;
j++;
}
else
{
j=next[j];
if(j==-1)
{
i++;j=0;
}
}
if(j==L2)
k++;
}
return k;
}
int main()
{
int t,i,j,k;
scanf("%d",&t);
while(t--)
{
scanf("%s",s);
scanf("%s",e);
k=kmp(e,s);
printf("%d\n",k);
}
return  0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  字符串 kmp poj