您的位置:首页 > 编程语言 > C语言/C++

1510[Mispelling]

2013-10-17 16:52 316 查看


Description

Misspelling is an art form that students seem to excel at. Write a program that removes the n th character from an input string.

***********************************************************

看例子马上就明白了


Sample Input


4
4 MISSPELL
1 PROGRAMMING
7 CONTEST
3 BALLOON



Sample Output


1 MISPELL
2 ROGRAMMING
3 CONTES
4 BALOON


代码:

#include<iostream>
#include<string>

using namespace std;

int main()
{
string w;
int n, m;
cin >> n;
int count = 1;
while( n-- )
{
cin >> m >> w;
cout << count << " ";
for(int i = 0; i < w.length(); i++)
if( i != m-1 )
cout << w[i];
cout << endl;
count++;
}
//	system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  c++ sicily