您的位置:首页 > 其它

Knights of the Round Table 补图, 双连通分量,奇圈,二分图,染色(交叉染色),(tarjan)

2013-10-16 17:00 169 查看
[align=left]Problem Description[/align]
Being a knight is a very attractive career: searching for the Holy Grail, saving damsels in distress, and drinking with the other knights are fun things to do. Therefore, it is not very surprising that in recent years the kingdom of King Arthur has experienced an unprecedented increase in the number of knights. There are so many knights now, that it is very rare that every Knight of the Round Table can come at the same time to Camelot and sit around the round table; usually only a small group of the knights isthere, while the rest are busy doing heroic deeds around the country.

Knights can easily get over-excited during discussions-especially after a couple of drinks. After some unfortunate accidents, King Arthur asked the famous wizard Merlin to make sure that in the future no fights break out between the knights. After studying the problem carefully, Merlin realized that the fights can only be prevented if the knights are seated according to the following two rules:

The knights should be seated such that two knights who hate each other should not be neighbors at the table. (Merlin has a list that says who hates whom.) The knights are sitting around a roundtable, thus every knight has exactly two neighbors.

An odd number of knights should sit around the table. This ensures that if the knights cannot agree on something, then they can settle the issue by voting. (If the number of knights is even, then itcan happen that ``yes" and ``no" have the same number of votes, and the argument goes on.)

Merlin will let the knights sit down only if these two rules are satisfied, otherwise he cancels the meeting. (If only one knight shows up, then the meeting is canceled as well, as one person cannot sit around a table.) Merlin realized that this means that there can be knights who cannot be part of any seating arrangements that respect these rules, and these knights will never be able to sit at the Round Table (one such case is if a knight hates every other knight, but there are many other possible reasons). If a knight cannot sit at the Round Table, then he cannot be a member of the Knights of the Round Table and must be expelled from the order. These knights have to be transferred to a less-prestigious order, such as the Knights of the Square Table, the Knights of the Octagonal Table, or the Knights of the Banana-Shaped Table. To help Merlin, you have to write a program that will determine the number of knights that must be expelled.

[align=left]Input[/align]
The input contains several blocks of test cases. Each case begins with a line containing two integers 1 ≤ n ≤ 1000 and 1 ≤ m ≤ 1000000 . The number n is the number of knights. The next m lines describe which knight hates which knight. Each of these m lines contains two integers k1 and k2 , which means that knight number k1 and knight number k2 hate each other (the numbers k1 and k2 are between 1 and n ).

The input is terminated by a block with n = m = 0 .

[align=left]Output[/align]
For each test case you have to output a single integer on a separate line: the number of knights that have to be expelled.

[align=left]Sample Input[/align]

5 5
1 4
1 5
2 5
3 4
4 5
0 0

[align=left]Sample Output[/align]

2

***************************************************************************************************************************
找双连通分量,
判断是否为奇圈时:用染色来判断,如果无法进行交叉染色,则为奇圈,否则不是。
求补图,即能相互在一起的骑士的集合,最后留下的即为被剔除的。
***************************************************************************************************************************

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <stack>
#include <queue>
#define MAX 1005
using namespace std;
struct node
{
int to,next;
};
struct Eage
{
int start,end;
};
int N,M;
bool cnt[MAX][MAX];
node edge[MAX*100];
int head[MAX];
int index;
int dfn[MAX],low[MAX];
int time;
stack <Eage> sta;
int color[MAX];
bool flag[MAX];
queue <int> Q;

bool mark[MAX];

void addNode(int from,int to)
{
edge[index].to = to;
edge[index].next = head[from];
head[from] = index++;
edge[index].to = from;
edge[index].next = head[to];
head[to] = index++;
}

void convert()
{
index = 0;
memset(head,-1,sizeof(head));
for(int i=1;i<=N;i++)
{
for(int j=i+1;j<=N;j++)
{
if(!cnt[i][j])
addNode(i,j);
}
}
}
bool toColor(int now)
{
while(!Q.empty())
Q.pop();
Q.push(now);
while(!Q.empty())
{
int cur = Q.front();
Q.pop();
for(int i=head[cur];i!=-1;i=edge[i].next)
{
int to=edge[i].to;
if(!flag[to])
continue;
if(!color[to])
{
color[to]=-color[cur];
Q.push(to);
}
else if(color[to] == color[cur])
return true;
}
}
return false;
}

void tarjan(int cur,int fat)
{
dfn[cur]=low[cur]=++time;
for(int i=head[cur];i!=-1;i=edge[i].next)
{
int to=edge[i].to;
if(to!=fat && dfn[to]<dfn[cur])
{
if(!dfn[to])
{
Eage eg;
eg.start=cur;
eg.end=to;
sta.push(eg);
tarjan(to,cur);
low[cur]=min(low[cur],low[to]);
if(dfn[cur]<=low[to])//存在连通分量 出栈标记;
{
memset(flag,0,sizeof(flag));
while(!sta.empty())
{
Eage s=sta.top();
sta.pop();
if(s.start == eg.start && s.end == eg.end)
break;
flag[s.start]=true;
flag[s.end]=true;
}
memset(color,0,sizeof(color));
color[cur]=1;
if(toColor(cur))
{
mark[cur]=true;
for(int j=1;j<=N;j++)
if(flag[j])
mark[j]=true;
}
}
}
else
low[cur]=min(low[cur],dfn[to]);
}
}
}

void solve()
{
memset(dfn,0,sizeof(dfn));
time = 0;
for(int i=1;i<=N;i++)
if(!dfn[i])
tarjan(i,-1);
}

int main()
{
while(scanf("%d%d",&N,&M))
{
if(!N && !M)
break;
memset(cnt,0,sizeof(cnt));
memset(mark,0,sizeof(mark));
for(int i=1;i<=M;i++)
{
int s,e;
scanf("%d%d",&s,&e);
cnt[s][e]=cnt[e][s]=true;
}
convert();
solve();
int ret = 0;
for(int i=1;i<=N;i++)
if(mark[i])
ret ++;
printf("%d\n",N-ret);
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: