您的位置:首页 > 其它

poj1704 Georgia and Bob

2013-09-30 22:07 183 查看
Georgia and Bob

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 6845 Accepted: 2020
Description
Georgia and Bob decide to play a self-invented game. They draw a row of grids on paper, number the grids from left to right by 1, 2, 3, ..., and place N chessmen on different grids, as shown in the following figure for example:



Georgia and Bob move the chessmen in turn. Every time a player will choose a chessman, and move it to the left without going over any other chessmen or across the left edge. The player can freely choose number of steps the chessman moves, with the constraint
that the chessman must be moved at least ONE step and one grid can at most contains ONE single chessman. The player who cannot make a move loses the game.

Georgia always plays first since "Lady first". Suppose that Georgia and Bob both do their best in the game, i.e., if one of them knows a way to win the game, he or she will be able to carry it out.

Given the initial positions of the n chessmen, can you predict who will finally win the game?

Input
The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case contains two lines. The first line consists of one integer N (1 <= N <= 1000), indicating the
number of chessmen. The second line contains N different integers P1, P2 ... Pn (1 <= Pi <= 10000), which are the initial positions of the n chessmen.
Output
For each test case, prints a single line, "Georgia will win", if Georgia will win the game; "Bob will win", if Bob will win the game; otherwise 'Not sure'.
Sample Input
2
3
1 2 3
8
1 5 6 7 9 12 14 17

Sample Output
Bob will win
Georgia will win

阶梯博弈,主要就是把两个球之间的空格数,当成石子,这样,分成几堆的石子,化成了取石子的游戏,这样,就可以解决了!

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
using namespace std;
#define M 10050
int pri[M];
int main()
{
int tcase,n,i,ans;
scanf("%d",&tcase);
while(tcase--){
scanf("%d",&n);
for(i=1;i<=n;i++){
scanf("%d",&pri[i]);
}
sort(pri+1,pri+n+1);
ans=0;i--;
while(i>1){
ans^=(pri[i]-pri[i-1]-1);i=i-2;
}
if(n&1)ans^=pri[1]-1;
if(ans)printf("Georgia will win\n");
else printf("Bob will win\n");

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: