您的位置:首页 > 产品设计 > UI/UE

POJ 1679 The Unique MST 次小生成树入门题

2013-09-27 21:48 246 查看
点击打开链接

The Unique MST

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 18120 Accepted: 6287
Description

Given a connected undirected graph, tell if its minimum spanning tree is unique. 

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties: 

1. V' = V. 

2. T is connected and acyclic. 

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all
the edges in E'. 

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a
triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.
Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.
Sample Input
2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output
3
Not Unique!

Source

POJ Monthly--2004.06.27 srbga@POJ
题意是说给出一个无向图,判断它的最小生成树是否唯一。
思路就是先求出最小生成树,然后再求次小生成树,如果相等,则不唯一,否则唯一。
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define M 107
#define inf 0x3f3f3f
using namespace std;
int g[M][M],path[M][M];//path求的是i到j最大的边权
int dist[M],pre[M],vis[M];
bool used[M][M];//是否在最小生成树中
int n,m,mst;

void init()
{
for(int i=0;i<=n;i++)
for(int j=i+1;j<=n;j++)
g[i][j]=g[j][i]=inf;

}

int prime()
{
int mst=0;
memset(path,0,sizeof(path));
memset(vis,0,sizeof(vis));
memset(used,0,sizeof(used));
vis[1]=1;
for(int i=1;i<=n;i++)
{
dist[i]=g[1][i];
pre[i]=1;
}
for(int i=1;i<n;i++)
{
int u=-1;
for(int j=1;j<=n;j++)
{
if(!vis[j])
if(u==-1||dist[j]<dist[u])
u=j;
}
used[u][pre[u]]=used[pre[u]][u]=true;//加入mst
mst+=g[pre[u]][u];
vis[u]=1;
for(int j=1;j<=n;j++)
{
if(vis[j]&&j!=u)//从u到j这条路径上最大边的权值
path[j][u]=path[u][j]=max(path[j][pre[u]],dist[u]);
if(!vis[j])
if(dist[j]>g[u][j])//更新相邻节点的距离
{
dist[j]=g[u][j];
pre[j]=u;//记录他的前驱
}
}
}
return mst;
}

int second_tree()//求次小生成树
{
int res=inf;
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
if(i!=j&&!used[i][j])
res=min(res,mst-path[i][j]+g[i][j]);//删除树上权值最大的路径并且加上这条路径其它边
return res;
}

int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&m);
init();
int u,v,w;
while(m--)
{
scanf("%d%d%d",&u,&v,&w);
g[u][v]=g[v][u]=w;
}
mst=prime();
int second_mst=second_tree();
if(second_mst==mst)
printf("Not Unique!\n");
else
printf("%d\n",mst);

}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: