您的位置:首页 > 其它

dp训练 1003

2013-09-11 14:07 309 查看


Constructing Roads In JGShining's Kingdom


Time Limit : 2000/1000ms
(Java/Other)   Memory
Limit : 65536/32768K (Java/Other)


Total Submission(s) :
50   Accepted
Submission(s) : 16


Font: Times New
Roman | Verdana | Georgia


Font Size: ← →


Problem Description

JGShining's kingdom consists of 2n(n is no more than 500,000) small
cities which are located in two parallel lines.

Half of these cities are rich in resource (we call them rich
cities) while the others are short of resource (we call them poor
cities). Each poor city is short of exactly one kind of resource
and also each rich city is rich in exactly one kind of resource.
You may assume no two poor cities are short of one same kind of
resource and no two rich cities are rich in one same kind of
resource. 

With the development of industry, poor cities wanna import resource
from rich ones. The roads existed are so small that they're unable
to ensure the heavy trucks, so new roads should be built. The poor
cities strongly BS each other, so are the rich ones. Poor cities
don't wanna build a road with other poor ones, and rich ones also
can't abide sharing an end of road with other rich ones. Because of
economic benefit, any rich city will be willing to export resource
to any poor one.

Rich citis marked from 1 to n are located in Line I and poor ones
marked from 1 to n are located in Line II. 

The location of Rich City 1 is on the left of all other cities,
Rich City 2 is on the left of all other cities excluding Rich City
1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but
on the left of all other cities ... And so as the poor
ones. 

But as you know, two crossed roads may cause a lot of traffic
accident so JGShining has established a law to forbid constructing
crossed roads.

For example, the roads in Figure I are forbidden.



In order to build as many roads as possible, the young and handsome
king of the kingdom - JGShining needs your help, please help him.
^_^


Input

Each test case will begin with a line containing an integer n(1 ≤ n
≤ 500,000). Then n lines follow. Each line contains two integers p
and r which represents that Poor City p needs to import resources
from Rich City r. Process to the end of file.


Output

For each test case, output the result in the form of
sample. 

You should tell JGShining what's the maximal number of road(s) can
be built. 


Sample Input

2
1 2
2 1
3
1 2
2 3
3 1


Sample Output

Case 1:
My king, at most 1 road can be built.

Case 2:
My king, at most 2 roads can be built.


本题也是最长上升子序列 
   
同以往不一样的是,需要在时间上做优化 
   
以往是开一数组,假设为f[i]表示到i能修多少路 
   
到计算f[q]时,需要遍历q之前的,找到a[i]<a[q](a[]存数据)且f[]最大的,然后加1,就是f[q],这样太浪费时间 
   
一种优化是把f[]相同的合并 
   
于是,像本题,用dp[i]存长度为i的最小的数据,如本题存修i条路时,号码最小的富裕城市 
   
到计算dp[q]时,给root[q](存和q有修路意向的富裕城市)找一个合适的 
   
地方(不比root[q]小,比他小的会与他交叉,若它前面的数在dp[m],则他即将放在dp[n+1],表明修第m+1条路时,它的号码最小) 
   
若这地方原来就有上数据,即low(root[q]的位置是由low找出来的,low是root[q]的下标)<=len,直接覆盖,算是更新数据; 
   
若low>len,把root[q]放到dp[low]后,还要让len更新到当前low,当然,low最多比len大1.

#include<stdio.h>
 
int num=1;  
int root[500100],dp[500100];  
void sol(int n)  
{  
    int low,up,mid,i,len;
 
    len=1;
 
    dp[1]=root[1];
 
   
for(i=2;i<=n;i++)  
    {
 
     
  low=1;  
     
  up=len;  
     
  while(low<=up)
 
     
  {  
     
     
mid=(low+up)>>1;
 
     
     
if(dp[mid]>=root[i])  
     
     
    up=mid-1;
 
     
      else
low=mid+1;  
     
  }  
     
  dp[low]=root[i];  
     
  if(low>len)
 
     
      len++;
 
    }
 
    printf("Case
%d:\n",num++);  
    printf("My king, at most
%d road",len);  
    if(len>1)
 
     
  printf("s");  
    printf(" can be
built.\n\n");  
}  
int main()  
{  
    int n,i,no;
 
   
while(scanf("%d",&n)!=-1)  
    {
 
     
  for(i=1;i<=n;i++)
 
     
  {  
     
     
scanf("%d",&no);  
     
     
scanf("%d",&root[no]);  
     
  }  
     
  sol(n);  
    }
 
    return 0;
 
}  

//最长上升子序列(n^2)模板
//入口参数:1.数组名称 2.数组长度(注意从1号位置开始)
template<class T>
int LIS(T a[],int n)
{
    int i,j;
    int ans=1;
    int m=0;
    int *dp=new
int[n+1];
    dp[1]=1;
   
for(i=2;i<=n;i++)
    {
     
  m=0;
     
  for(j=1;j<i;j++)
     
  {
     
     
if(dp[j]>m&&a[j]<a[i])
     
     
    m=dp[j];
     
  }
     
  dp[i]=m+1;
     
  if(dp[i]>ans)
     
     
ans=dp[i];
    }
    return ans;
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: