您的位置:首页 > 其它

HDU 1150 Machine Schedule (匈牙利算法 最小顶点覆盖= 最大匹配数)

2013-09-01 16:21 363 查看

Machine Schedule

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 4641 Accepted Submission(s): 2286


[align=left]Problem Description[/align]
As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type
of schedule desired. Here we consider a 2-machine scheduling problem.

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, …, mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, … , mode_m-1. At the beginning they are both work at mode_0.

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine
B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y.

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to
a suitable machine, please write a program to minimize the times of restarting machines.

[align=left]Input[/align]
The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs,
each line is a triple: i, x, y.

The input will be terminated by a line containing a single zero.

[align=left]Output[/align]
The output should be one integer per line, which means the minimal times of restarting machine.

[align=left]Sample Input[/align]

5 5 10
0 1 1
1 1 2
2 1 3
3 1 4
4 2 1
5 2 2
6 2 3
7 2 4
8 3 3
9 4 3
0

[align=left]Sample Output[/align]

3

这题意,有k
个任务
A 机器有
n 个模式,
B 机器有
m 个模式,对于每一台机器不同模式之间需要切换,问完成
k 个任务需要至少切换多少次。
这题其实就是求最小顶点覆盖,最小顶点覆盖=
最大匹配数。
 
 
import java.io.*;
import java.util.*;
public class Main {
int n,m,k;
int[][] map;//地图
int[] link=new int[1000];//记录匹配信息
boolean[] mark=new boolean[1000];//标志每个点是否使用
public static void main(String[] args) {
new Main().work();
}
void work(){
Scanner sc=new Scanner(new BufferedInputStream(System.in));
while(sc.hasNext()){
n=sc.nextInt();
if(n==0) break;
m=sc.nextInt();
k=sc.nextInt();
map=new int[1000][1000];
//建图
for(int i=0;i<k;i++){
int p=sc.nextInt();
int x=sc.nextInt();
int y=sc.nextInt();
map[x][y]=1;
}
Arrays.fill(link, 0);
int ans=0;
for(int i=1;i<=n;i++){
Arrays.fill(mark,false);
if(DFS(i))
ans++;
}
System.out.println(ans);
}
}
boolean DFS(int x){
for(int i=1;i<=m;i++){
if(map[x][i]==1&&!mark[i]){
mark[i]=true;
if(link[i]==0||DFS(link[i])){
link[i]=x;
return true;
}
}
}
return false;
}
}


 
 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐