您的位置:首页 > 其它

hdu 1004-统计出现次数最多的字符串

2013-08-22 22:57 344 查看


Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 58628 Accepted Submission(s): 21533



Problem Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0


Sample Output

red
pink

#include <iostream>
#include <cstdio>
#include <ctime>
#include <cstdlib>
#include <queue>
#include <vector>
#include <set>
#include <map>
#include <algorithm>
#include <string>
using namespace std;

int main() {
int n;
string s, x;
map <string, int> xx;
map <string, int>::iterator p;
while(cin >> n, n) {
xx.clear();
while(n--) {
cin >> s;
++xx[s];
}
for(p = xx.begin(); p != xx.end(); ++p) {
if (p->second > n)  n = p->second;
x = p->first;
}
cout << x << endl;
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: