您的位置:首页 > 其它

Poj 3279 & 1222(开关问题)

2013-08-15 22:51 706 查看
Fliptile

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 2648Accepted: 1022
Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤N ≤ 15) of square tiles,
each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather
large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the
output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input

Line 1: Two space-separated integers: M and N

Lines 2..M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white
Output

Lines 1..M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.
Sample Input
4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output
0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

Source

USACO 2007 Open Silver

经典的翻转问题。方法是枚举第一行,然后下面的各种操作就确定了。

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<vector>
#include<cstring>
#include<queue>
#include<stack>
using namespace std;
const int maxn = 20 + 5;
const int INF = 2000000000;
typedef  pair<int, int> P;
typedef long long LL;
const int dx[5] = {0,-1,1,0,0};
const int dy[5] = {0,0,0,-1,1};

int m,n;
int M[maxn][maxn];
int ans[maxn][maxn];
int tem[maxn][maxn];

int get(int x,int y){
    int c = M[x][y];
    for(int i = 0;i < 5;i++){
        int x2 = x + dx[i];
        int y2 = y + dy[i];
        if(0 <= x2 && x2 < m && 0 <= y2 && y2 < n){
            c += tem[x2][y2];
        }
    }
    return c%2;
}

int calc(){
    for(int i = 1;i < m;i++){
        for(int j = 0;j < n;j++){
            if(get(i-1,j) != 0){
                tem[i][j] = 1;
            }
        }
    }
    for(int j = 0;j < n;j++){
        if(get(m-1,j) != 0){
            return -1;
        }
    }

    int res = 0;
    for(int i = 0;i < m;i++){
        for(int j = 0;j < n;j++){
            res += tem[i][j];
        }
    }
    return res;
}

void solve(){
    int res = -1;
    for(int i = 0;i < 1 << n;i++){
        memset(tem,0,sizeof(tem));
        for(int j = 0;j < n;j++){
            tem[0][n-j-1] = i >> j & 1;

        }
        int num = calc();
        if(num >= 0 && (res < 0 || res > num)){
            res = num;
            memcpy(ans,tem,sizeof(tem));
        }
    }
    if(res < 0){
        printf("IMPOSSIBLE\n");
    }
    else{
        for(int i = 0;i < m;i++){
            for(int j = 0;j < n;j++){
                printf("%d%c",ans[i][j],j+1==n?'\n':' ');
            }
        }
    }
}

int main(){
    while(scanf("%d%d",&m,&n) != EOF){
        for(int i = 0;i < m;i++){
            for(int j = 0;j < n;j++){
                scanf("%d",&M[i][j]);
            }
        }
        solve();
    }
    return 0;
}


这题的代码,简单改改后可以直接过1222那题。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: