您的位置:首页 > 其它

HDU 4585 Shaolin

2013-08-10 17:16 274 查看

Shaolin

[align=left]Problem Description[/align]
Shaolin temple is very famous for its Kongfu monks.A lot of young men go to Shaolin temple every year, trying to be a monk there. The master of Shaolin evaluates a young man mainly by his talent on understanding the Buddism scripture, but fighting skill is also taken into account.
When a young man passes all the tests and is declared a new monk of Shaolin, there will be a fight , as a part of the welcome party. Every monk has an unique id and a unique fighting grade, which are all integers. The new monk must fight with a old monk whose fighting grade is closest to his fighting grade. If there are two old monks satisfying that condition, the new monk will take the one whose fighting grade is less than his.
The master is the first monk in Shaolin, his id is 1,and his fighting grade is 1,000,000,000.He just lost the fighting records. But he still remembers who joined Shaolin earlier, who joined later. Please recover the fighting records for him.

[align=left]Input[/align]
There are several test cases.
In each test case:
The first line is a integer n (0 <n <=100,000),meaning the number of monks who joined Shaolin after the master did.(The master is not included).Then n lines follow. Each line has two integer k and g, meaning a monk's id and his fighting grade.( 0<= k ,g<=5,000,000)
The monks are listed by ascending order of jointing time.In other words, monks who joined Shaolin earlier come first.
The input ends with n = 0.

[align=left]Output[/align]
A fight can be described as two ids of the monks who make that fight. For each test case, output all fights by the ascending order of happening time. Each fight in a line. For each fight, print the new monk's id first ,then the old monk's id.

[align=left]Sample Input[/align]

3
2 1
3 3
4 2
0

[align=left]Sample Output[/align]

2 1
3 2
4 2

[align=left]Source[/align]
2013ACM-ICPC杭州赛区全国邀请赛

思路: 只要熟悉了set ,这个题写法就简单了,记忆中set的应用几乎每次预选赛上都会出现一次,万变不离其宗。

#include <iostream>
#include <string.h>
#include <string>
#include <algorithm>
#include <stdio.h>
#include <queue>
#include <set>
#include <limits.h>
#define Max(a,b) ((a)>(b)?(a):(b))
#define Min(a,b) ((a)<(b)?(a):(b))
using namespace std ;
struct Me{
struct Man{
int id ;
int fight ;
Man(){}
Man(int i ,int f):id(i),fight(f){}
friend bool operator<(const Man A ,const Man B){
return A.fight<B.fight ;
}
};
int N ;
Me(){}
Me(int n):N(n){}
void gao_qi(){
set<Man>st ;
set<Man>::iterator p ;
st.clear() ;
st.insert(Man(1,1000000000)) ;
while(N--){
Man man ;
scanf("%d%d",&man.id,&man.fight) ;
p=st.upper_bound(man) ;
if(p!=st.begin()){
int id=p->id ;
int fight=p->fight ;
p-- ;
if(man.fight-(p->fight)<=fight-man.fight)
printf("%d %d\n",man.id,p->id) ;
else
printf("%d %d\n",man.id,id) ;
}
else
printf("%d %d\n",man.id,p->id) ;
st.insert(man) ;
}
}
};
int main(){
int n ;
while(scanf("%d",&n)){
if(n==0)
break ;
Me me(n) ;
me.gao_qi() ;
}
return 0 ;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: