您的位置:首页 > 其它

UVA 539 The Settlers of Catan(回溯法)

2013-08-04 11:29 471 查看
 


  The Settlers of Catan 
Within Settlers of Catan, the 1995 German game of the year, players attempt to dominate an island by building roads, settlements and cities across its uncharted wilderness.

You are employed by a software company that just has decided to develop a computer version of this game, and you are chosen to implement one of the game's special rules:

When the game ends, the player who built the longest road gains two extra victory points.

The problem here is that the players usually build complex road networks and not just one linear path. Therefore, determining the longest road is not trivial (although human players usually see it immediately).

Compared to the original game, we will solve a simplified problem here: You are given a set of nodes (cities) and a set of edges (road segments) of length 1 connecting the nodes. The longest road is defined as the longest path within the network that doesn't
use an edge twice. Nodes may be visited more than once, though.

Example: The following network contains a road of length 12.

o        o -- o        o
\      /      \      /
o -- o        o -- o
/      \      /      \
o        o -- o        o -- o
\      /
o -- o


Input 

The input file will contain one or more test cases.
The first line of each test case contains two integers: the number of nodes n ( 

)
and the number of edges m ( 

). The next m lines
describe the m edges. Each edge is given by the numbers of the two nodes connected by it. Nodes are numbered from 0 to n-1. Edges are undirected. Nodes have degrees of three or less. The network is not
neccessarily connected.

Input will be terminated by two values of 0 for n and m.

Output 

For each test case, print the length of the longest road on a single line.

Sample Input 

3 2
0 1
1 2
15 16
0 2
1 2
2 3
3 4
3 5
4 6
5 7
6 8
7 8
7 9
8 10
9 11
10 12
11 12
10 13
12 14
0 0


Sample Output 

2
12


 

奥呵呵,第一次自己用回溯法写了一个题,好高兴!

英语功底不好,所以理解题意就浪费了很长时间,但我最后还是懂啦!

大致题意:给你n个点,分别为0~n-1,给你m条路径,求出其中最长的路径。

 

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49

#include <iostream>
#include <cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
int m,n;
int v[50][50],e[50][50];
int ma;
void dfs(int x,int ans)
{  if(ma<ans)
ma=ans;
for(int i=0;i<n;i++)
{
if(!v[x][i]&&e[x][i])
{
v[i][x]=1;v[x][i]=1;
dfs(i,ans+1);

v[i][x]=0;v[x][i]=0;
}

}

}
int main()
{
int a,b,i,j;
while(~scanf("%d%d",&n,&m))
{
if(n==0&&m==0) break;

ma=0;

memset( v , 0 , sizeof ( v ) );

memset( e , 0 , sizeof ( e ) );

for(i=0;i<m;i++)
{
scanf("%d%d",&a,&b);
e[a][b]=e[b][a]=1;
}
for(i=0;i<m;i++)
dfs(i,0);
printf("%d\n",ma);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  搜索回溯法