您的位置:首页 > 其它

poj 1002-487-3279

2013-08-02 00:31 218 查看
点击打开链接

487-3279

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 218558 Accepted: 38099
Description

Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP. Sometimes only part of
the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino's by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could order your pizza from Pizza
Hut by calling their ``three tens'' number 3-10-10-10. 

The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows: 

A, B, and C map to 2 

D, E, and F map to 3 

G, H, and I map to 4 

J, K, and L map to 5 

M, N, and O map to 6 

P, R, and S map to 7 

T, U, and V map to 8 

W, X, and Y map to 9 

There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010. 

Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.) 

Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number. 

Input

The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers in the directory, with each number
alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters. 

Output

Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number appears in the directory. Arrange
the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line: 

No duplicates. 

Sample Input
12
4873279
ITS-EASY
888-4567
3-10-10-10
888-GLOP
TUT-GLOP
967-11-11
310-GINO
F101010
888-1200
-4-8-7-3-2-7-9-
487-3279

Sample Output
310-1010 2
487-3279 4
888-4567 3


没什么好说的,就是建立一个哈希表,记录一下出现的次数,使用vector记录号码

#include<stdio.h>
#include<iostream>
//#include<set>
#include<algorithm>
#include<string>
#include<vector>
using namespace std;

int myhash[] = {2, 2, 2, 3, 3, 3, 4, 4, 4, 5, 5, 5, 6, 6, 6, 7, 0, 7, 7, 8, 8, 8, 9, 9, 9};
int _hash[10][10][10][10][10][10][10];
vector<string> v;
int main()
{
// freopen("test.txt", "r", stdin);
// memset(_hash, 0, sizeof(_hash));
string str;
char str2[150];
int num;
int t;
scanf("%d", &num);
while(num--)
{
scanf("%s", str2);
int i;
for(i = 0; str2[i]; i++)
{
if(str2[i] >='0' && str2[i] <= '9')
str += str2[i];
else if(str2[i] >= 'A' && str2[i] < 'Z')
{
str += myhash[str2[i] - 'A'] + '0';
}

}
while(str.length() < 7)
{
str = '0' + str;
}
if(_hash[str[0] - '0'][str[1] - '0'][str[2] - '0'][str[3] - '0'][str[4] - '0'][str[5] - '0'][str[6] - '0'] == 0)
{
v.push_back(str);
}
_hash[str[0] - '0'][str[1] - '0'][str[2] - '0'][str[3] - '0'][str[4] - '0'][str[5] - '0'][str[6] - '0'] ++;
str = "";
}
sort(v.begin(), v.end());
vector<string>::iterator p;
int flag = 0;
for(p = v.begin(); p != v.end(); p++)
{
t = _hash[(*p)[0] - '0'][(*p)[1] - '0'][(*p)[2] - '0'][(*p)[3] - '0'][(*p)[4] - '0'][(*p)[5] - '0'][(*p)[6] - '0'];
if(t > 1)
{
printf("%s-%s %d\n", (*p).substr(0, 3).c_str(), (*p).substr(3, 4).c_str(), t);
flag = 1;
}
}
if(flag == 0)
printf("No duplicates.");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: