您的位置:首页 > 其它

hdu 4508 湫湫系列故事――减肥记I(完全背包)

2013-08-01 00:11 211 查看
  对于吃货来说,过年最幸福的事就是吃了,没有之一!

  但是对于女生来说,卡路里(热量)是天敌啊!

  资深美女湫湫深谙“胖来如山倒,胖去如抽丝”的道理,所以她希望你能帮忙制定一个食谱,能使她吃得开心的同时,不会制造太多的天敌。

  当然,为了方便你制作食谱,湫湫给了你每日食物清单,上面描述了当天她想吃的每种食物能带给她的幸福程度,以及会增加的卡路里量。
 

Input

  输入包含多组测试用例。

  每组数据以一个整数n开始,表示每天的食物清单有n种食物。 

  接下来n行,每行两个整数a和b,其中a表示这种食物可以带给湫湫的幸福值(数值越大,越幸福),b表示湫湫吃这种食物会吸收的卡路里量。

  最后是一个整数m,表示湫湫一天吸收的卡路里不能超过m。

  [Technical Specification]

  1. 1 <= n <= 100

  2. 0 <= a,b <= 100000

  3. 1 <= m <= 100000

 

Output

  对每份清单,输出一个整数,即满足卡路里吸收量的同时,湫湫可获得的最大幸福值。
 

Sample Input

3
3 3
7 7
9 9
10
5
1 1
5 3
10 3
6 8
7 5
6

 

Sample Output

10
20

 

题目大意:要求在给定的卡路里值求最大的幸福值。

解题思路:典型的无限背包问题,dp表示当前背包容量下的最大幸福值,bo表示当前背包值是否可以被组成。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define N 105
#define M 100005
struct coor{
int value;
int ka;
}s
;

int bo[M], dp[M];
int n, f;
int cmp(const coor &a, const coor &b){
return a.ka < b.ka;
}
int MAX(int a, int b){
return a>b?a:b;
}

int main(){
while (scanf("%d", &n) != EOF){
//Init.
memset(s, 0, sizeof(s));
memset(dp, 0, sizeof(dp));
memset(bo, 0, sizeof(bo));

// Read.
for (int i = 0; i < n; i++)
scanf("%d%d", &s[i].value, &s[i].ka);
scanf("%d", &f);
sort (s, s + n, cmp);

bo[0] = 1;
for (int i = 0; i < n; i++){
for (int j = 0; j <= f; j++){
if (bo[j] && s[i].ka + j <= f){
dp[s[i].ka + j] = MAX(dp[s[i].ka + j], s[i].value + dp[j]);
bo[s[i].ka + j] = 1;
}
}
}

int t = 0;
for (int i = 0; i <= f; i++)
if (t < dp[i])
t = dp[i];
printf("%d\n", t);
}
return 0;}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: