您的位置:首页 > 其它

UVA 10790 - How Many Points of Intersection(数学)

2013-07-27 18:04 1121 查看



How Many Points of Intersection?

We have two rows. There are a dots on the top row and b dots on the bottom row. We draw line segments connecting every dot on the top row with every dot on the bottom row. The dots are arranged
in such a way that the number of internal intersections among the line segments is maximized. To achieve this goal we must not allow more than two line segments to intersect in a point. The intersection points on the top row and the bottom are not included
in our count; we can allow more than two line segments to intersect on those two rows. Given the value of a and b, your task is to compute P(a, b),
the number of intersections in between the two rows. For example, in the following figure a = 2 and b = 3. This figure illustrates that P(2, 3) = 3.




Input

Each line in the input will contain two positive integers a ( 0 < a

20000)
and b ( 0 < b

20000). Input is terminated by a line where both a and b are
zero. This case should not be processed. You will need to process at most 1200 sets of inputs.


Output

For each line of input, print in a line the serial of output followed by the value of P(a, b). Look at the output for sample input for details. You can assume that the output for the test cases will fit in 64-bit signed
integers.


Sample Input

2 2
2 3
3 3
0 0



Sample Output

Case 1: 1
Case 2: 3
Case 3: 9


===================================

/article/6233853.html

#include <iostream>
#include <cstdio>

using namespace std;

int main()
{
int t=1;long long a,b;
while(~scanf("%d%d",&a,&b))
{
if(a==0&&b==0) break;
printf("Case %d: ",t++);
printf("%lld\n",b*(b-1)*a*(a-1)/4);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: