您的位置:首页 > 其它

poj 2021 Relative Relatives

2013-07-12 15:50 197 查看
Relative Relatives

Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 3330Accepted: 1456
Description

Today is Ted's 100th birthday. A few weeks ago, you were selected by the family to contact all of Ted's descendants and organize a surprise party. To make this task easier, you created an age-prioritized list of everyone descended from Ted. Descendants of the
same age are listed in dictionary order.

The only materials you had to aid you were birth certificates. Oddly enough, these birth certificates were not dated. They simply listed the father's name, the child's name, and the father's exact age when the baby was born.
Input

Input to this problem will begin with line containing a single integer n indicating the number of data sets. Each data set will be formatted according to the following description.

A single data set has 2 components:

Descendant Count - A line containing a single integer X (where 0 < X < 100) indicating the number of Ted's descendants.

Birth Certificate List - Data for X birth certificates, with one certificate's data per line. Each certificate's data will be of the format "FNAME CNAME FAGE" where:

FNAME is the father's name.

CNAME is the child's name.

FAGE is the integer age of the father on the date of CNAMEs birth.

Note:

Names are unique identifiers of individuals and contain no embedded white space.

All of Ted's descendants share Ted's birthday. Therefore, the age difference between any two is an integer number of years. (For those of you that are really picky, assume they were all born at the exact same hour, minute, second, etc... of their birth
year.)

You have a birth certificate for all of Ted's descendants (a complete collection).

Output

For each data set, there will be X+1 lines of output. The first will read, "DATASET Y", where Y is 1 for the first data set, 2 for the second, etc. The subsequent X lines constitute your age-prioritized list of Ted's descendants along with their ages using
the format "NAME AGE". Descendants of the same age will be listed in dictionary order.
Sample Input
2
1
Ted Bill 25
4
Ray James 40
James Beelzebub 17
Ray Mark 75
Ted Ray 20

Sample Output
DATASET 1
Bill 75
DATASET 2
Ray 80
James 40
Beelzebub 23
Mark 5

Source

South Central USA 2004

好久没做poj了。

这题意思就是Ted 100岁了,要你求其他人年龄。第一行是数据数量。

每组数据第一行是接下来行数,然后下面是俩名字一数字代表年龄差,要求出所有人年龄按从大到小输出(Ted不用输出),年龄相同按名字字符串大小。

反正BFS就ok了,存名字、年龄啊什么的聪明点就行了。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<map>
#include<queue>
#include<algorithm>
using namespace std;
struct node
{
    string a,b;
    int c;
}p[1000];
int n,num;
string name[1000];
int main()
{
    int t,no=1;
    scanf("%d",&t);
    while(t--)
    {
        map<string,int>age;
        scanf("%d",&n);
        num=0;
        for(int i=0;i<n;i++)
        {
            cin>>p[i].a>>p[i].b>>p[i].c;
            if(!age[p[i].a])
            {
                name[num++]=p[i].a;
                age[p[i].a]=-1;
            }
            if(!age[p[i].b])
            {
                name[num++]=p[i].b;
                age[p[i].b]=-1;
            }
        }
        queue<string>q;
        age["Ted"]=100;
        q.push("Ted");
        while(!q.empty())
        {
            string ss=q.front();
            q.pop();
            for(int i=0;i<n;i++)
            {
                if(age[p[i].a]==-1&&p[i].b==ss)
                {
                    age[p[i].a]=age[ss]+p[i].c;
                    q.push(p[i].a);
                }
                else if(age[p[i].b]==-1&&p[i].a==ss)
                {
                    age[p[i].b]=age[ss]-p[i].c;
                    q.push(p[i].b);
                }
            }
        }
        for(int i=0;i<num;i++)
        {
            for(int j=i+1;j<num;j++)
            {
                if(age[name[i]]<age[name[j]]||(age[name[i]]==age[name[j]]&&name[i]>name[j]))
                {
                    string ss=name[i];
                    name[i]=name[j];
                    name[j]=ss;
                }
            }
        }
        cout<<"DATASET "<<no++<<endl;
        for(int i=0;i<num;i++)
        {
            if(name[i]=="Ted")continue;
            else cout<<name[i]<<" "<<age[name[i]]<<endl;
        }
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: