您的位置:首页 > 其它

poj 1051 P,MTHBGWB(字符串,较麻烦)

2013-05-23 19:13 225 查看
1、http://poj.org/problem?id=1051

注意字符串那些需要清空,string 清空用 rstr="";

2、题目:

P,MTHBGWB

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 6800Accepted: 3913
Description
Morse code represents characters as variable length sequences of dots and dashes. In practice, characters in a message are delimited by short pauses. The following table shows the Morse code sequences:

A.-H....O---V...-
B-...I..P.--.W.--
C-.-.J.---Q--.-X-..-
D-..K-.-R.-.Y-.--
E.L.-..S...Z--..
F..-.M--T-  
G--.N-.U..-  
Note that four dot-dash combinations are unassigned. For the purposes of this problem we will assign them as follows (these are not the assignments for actual Morse code):

underscore..--period---.
comma.-.-question mark----
Thus, the message "ACM_GREATER_NY_REGION" is encoded as:

.- -.-. -- ..-- --. .-. . .- - . .-. ..-- -. -.-- ..-- .-. . --. .. --- -.

M.E. Ohaver proposed an encryption scheme based on mutilating Morse code. Her scheme replaces the pauses between letters, necessary because Morse is a variable-length encoding that is not prefix-free, with a string that identifies the number of dots and dashes
in each. For example, consider the message ".--.-.--". Without knowing where the pauses should be, this could be "ACM", "ANK", or several other possibilities. If we add length information, however, ".--.-.--242", then the code is unabiguous.

Ohaver's scheme has three steps, the same for encryption and decryption:

1. Convert the text to Morse code without pauses but with a string of numbers to indicate code lengths

2. Reverse the string of numbers

3. Convert the dots and dashes back into to text using the reversed string of numbers as code lengths

As an example, consider the encrypted message "AKADTOF_IBOETATUK_IJN". Converting to Morse code with a length string yields ".--.-.--..----..-...--..-...---.-.--..--.-..--...----.232313442431121334242". Reversing the numbers and decoding yields the original
message "ACM_GREATER_NY_REGION".

Input
This problem requires that you implement Ohaver's encoding algorithm. The input will consist of several messages encoded with Ohaver's algorithm. The first line of the input is an integer n that specifies the number of test cases.
The following n lines contain one message per line. Each message will use only the twenty-six capital letters, underscores, commas, periods, and question marks. Messages will not exceed 100 characters in length.
Output
For each message in the input, output the line number starting in column one, a colon, a space, and then the decoded message. The output format must be adhered to precisely.
Sample Input
5
AKADTOF_IBOETATUK_IJN
PUEL
QEWOISE.EIVCAEFNRXTBELYTGD.
?EJHUT.TSMYGW?EJHOT
DSU.XFNCJEVE.OE_UJDXNO_YHU?VIDWDHPDJIKXZT?E

Sample Output
1: ACM_GREATER_NY_REGION
2: PERL
3: QUOTH_THE_RAVEN,_NEVERMORE.
4: TO_BE_OR_NOT_TO_BE?
5: THE_QUICK_BROWN_FOX_JUMPS_OVER_THE_LAZY_DOG

Source
Greater New York 2001

[Submit] [Go Back] [Status] [Discuss
3、代码:

#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
char str[1110];
string rstr;
int rnum[1110];
char change[26][10]= {".-","-...","-.-.","-..",".","..-.","--.","....","..",
".---","-.-",".-..","--","-.","---",".--.","--.-",".-.","...","-","..-","...-",
".--","-..-","-.--","--.."
};
char change2[4][10]= {"..--","---.",".-.-","----"};
char find1(char c[])
{
for(int i=0; i<26; i++)
{
if(strcmp(c,change[i])==0)
return 'A'+i;
}
}
char find2(char c[])
{
if(strcmp(c,"..--")==0)
return '_';
else if(strcmp(c,"---.")==0)
return '.';
else if(strcmp(c,".-.-")==0)
return ',';
else if(strcmp(c,"----")==0)
return '?';
}
int find3(char c)
{
if(c=='_')
return 0;
else if(c=='.')
return 1;
else if(c==',')
return 2;
else if(c=='?')
return 3;
}
int main()
{
int t,cas=0;
cin>>t;
while(t--)
{
cas++;
cin>>str;
char ans[1110];
int len=strlen(str);
rstr="";
for(int i=0; i<len; i++)
{
if(str[i]>='A' && str[i]<='Z')
{
int tmp=str[i]-'A';
rstr+=change[tmp];
rnum[i]=strlen(change[tmp]);
}
else
{
int tmp=find3(str[i]);
rstr+=change2[tmp];
rnum[i]=strlen(change2[tmp]);
}
}
int aa=0;
int l=rstr.size();
int p=len-1,pp=0;
char temp[10];
memset(ans,0,sizeof(ans));
for(int i=0; i<l;)
{
memset(temp,0,sizeof(temp));
int k=0;
for(int j=i; j<i+rnum[p]; j++)
{
temp[k++]=rstr[j];
}
if(strcmp(temp,"..--")==0)
ans[pp]='_';
else if(strcmp(temp,"---.")==0)
ans[pp]='.';
else if(strcmp(temp,".-.-")==0)
ans[pp]=',';
else if(strcmp(temp,"----")==0)
ans[pp]='?';
else
ans[pp]=find1(temp);
i+=rnum[p];
p--;
pp++;
}
printf("%d: %s\n",cas,ans);
}
return 0;
}
/*
5 AKADTOF_IBOETATUK_IJN PUEL QEWOISE.EIVCAEFNRXTBELYTGD. ?EJHUT.TSMYGW?EJHOT DSU.XFNCJEVE.OE_UJDXNO_YHU?VIDWDHPDJIKXZT?E*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: