您的位置:首页 > 其它

USACO 1.3.3

2013-05-22 18:37 169 查看

Barn Repair

It was a dark and stormy night that ripped the roof and gates off the stalls that hold Farmer John's cows. Happily, many of the cows were on vacation, so the barn was not completely full.
The cows spend the night in stalls that are arranged adjacent to each other in a long line. Some stalls have cows in them; some do not. All stalls are the same width.
Farmer John must quickly erect new boards in front of the stalls, since the doors were lost. His new lumber supplier will supply him boards of any length he wishes, but the supplier can only deliver a small number
of total boards. Farmer John wishes to minimize the total length of the boards he must purchase.
Given M (1 <= M <= 50), the maximum number of boards that can be purchased; S (1 <= S <= 200), the total number of stalls; C (1 <= C <= S) the number of cows in the stalls, and the C occupied stall numbers (1 <=
stall_number <= S), calculate the minimum number of stalls that must be blocked in order to block all the stalls that have cows in them.
Print your answer as the total number of stalls blocked.

PROGRAM NAME: barn1

INPUT FORMAT

Line 1:M, S, and C (space separated)
Lines 2-C+1:Each line contains one integer, the number of an occupied stall.

SAMPLE INPUT (file barn1.in)

4 50 18
3
4
6
8
14
15
16
17
21
25
26
27
30
31
40
41
42
43

OUTPUT FORMAT

A single line with one integer that represents the total number of stalls blocked.

SAMPLE OUTPUT (file barn1.out)

25

[One minimum arrangement is one board covering stalls 3-8, one covering 14-21, one covering 25-31, and one covering 40-43.] 

这题一开始想了好久,后来看了NOCOW上的思路才会的,NOCOW上有4种思路,一个是正面贪心,一个是反面贪心,一个是DP,最后一种是直接考虑把间隙排序贪之。

我是反面去想,题目问最小木板长度,相当于求最大间隙长度,用总长去减当前最大的间隙即可。

/*
ID: xinming2
PROG: barn1
LANG: C++
*/
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <iostream>
#include <cstring>
#include <map>
#include <string>
#include <stack>

using namespace std;
int a[250];
int b[250];
bool cmp(const int a , const int b)
{
return a > b;
}
int main()
{
freopen("barn1.in","r",stdin);
freopen("barn1.out","w",stdout);
int m , s , c;
while(scanf("%d%d%d",&m , &s , &c)!=EOF)
{
for(int i = 0 ; i < c ; i++)
{
scanf("%d",&a[i]);
}
sort(a , a + c);
int ans = a[c - 1] - a[0] + 1;
for(int i = 0 ; i < c - 1 ; i++)
{
b[i] = a[i + 1] - a[i] - 1;
}
sort(b , b + c - 1, cmp);
for(int i = 0 ; i < m - 1&&i < c - 1; i++)
{
ans -= b[i];
//cout << b[i] << endl;
}
printf("%d\n",ans);
}
return 0;
}
/*

*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM 贪心