您的位置:首页 > 其它

uva 11300 - Spreading the Wealth(思维)

2013-05-09 21:23 323 查看



F. Spreading the Wealth

Problem

A Communist regime is trying to redistribute wealth in a village. They have have decided to sit everyone around a circular table. First, everyone has converted all of their properties to coins of equal value, such
that the total number of coins is divisible by the number of people in the village. Finally, each person gives a number of coins to the person on his right and a number coins to the person on his left, such that in the end, everyone has the same number of
coins. Given the number of coins of each person, compute the minimum number of coins that must be transferred using this method so that everyone has the same number of coins.

The Input

There is a number of inputs. Each input begins with n(n<1000001), the number of people in the village. nlines follow, giving the number of coins of each person
in the village, in counterclockwise order around the table. The total number of coins will fit inside an unsigned 64 bit integer.

The Output

For each input, output the minimum number of coins that must be transferred on a single line.

Sample Input

3
100
100
100
4
1
2
5
4


Sample Output

0
4


Problem setter: Josh Bao

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
const int mm=1000009;
long long f[mm];
long long d[mm];
long long aabs(long long x)
{
if(x<0)return -x;
return x;
}
/**
每个人可以从左一个人或右一人给,假设最后每个人都是m个最初为f[i],x[i]为拿给别人或从别人获得的
f[i]-x[i-1]+x[i+1]=m;{i 1-N}
x[i+1]=m-f[i]+x[i-1];
结果就是所有x[i]距离的绝对值。取中点最优
*/
int main()
{ int n;
while(~scanf("%d",&n))
{ long long sum=0;
for(int i=0;i<n;++i)
{scanf("%lld",&f[i]);sum+=f[i];}
sum/=n;
d[0]=0;///起始位
for(int i=1;i<n;++i)
d[i]=d[i-1]+sum-f[i];
sort(d,d+n);
int z=n/2;sum=0;
for(int i=0;i<n;++i)
sum+=aabs(d[i]-d[z]);
printf("%lld\n",sum);
}
}




F. Spreading the Wealth

Problem

A Communist regime is trying to redistribute wealth in a village. They have have decided to sit everyone around a circular table. First, everyone has converted all of their properties to coins of equal value, such
that the total number of coins is divisible by the number of people in the village. Finally, each person gives a number of coins to the person on his right and a number coins to the person on his left, such that in the end, everyone has the same number of
coins. Given the number of coins of each person, compute the minimum number of coins that must be transferred using this method so that everyone has the same number of coins.

The Input

There is a number of inputs. Each input begins with n(n<1000001), the number of people in the village. nlines follow, giving the number of coins of each person
in the village, in counterclockwise order around the table. The total number of coins will fit inside an unsigned 64 bit integer.

The Output

For each input, output the minimum number of coins that must be transferred on a single line.

Sample Input

3
100
100
100
4
1
2
5
4


Sample Output

0
4


Problem setter: Josh Bao
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: