您的位置:首页 > 其它

624&&背包问题&&方案输出

2013-04-14 23:22 218 查看
CD
You have a long drive by car ahead. You have a tape recorder, but unfortunately your best music is on CDs. You need to have it on tapes so the problem to solve is: you have a tape N minutes long. How to choose tracks from CD to get most out of tape space and have as short unused space as possible.

Assumptions:

number of tracks on the CD. does not exceed 20

no track is longer than N minutes

tracks do not repeat

length of each track is expressed as an integer number

N is also integer

Program should find the set of tracks which fills the tape best and print it in the same sequence as the tracks are stored on the CD

Input

Any number of lines. Each one contains value N, (after space) number of tracks and durations of the tracks. For example from first line in sample data: N=5, number of tracks=3, first track lasts for 1 minute, second one 3 minutes, next one 4 minutes

Output

Set of tracks (and durations) which are the correct solutions and string ``sum:" and sum of duration times.

Sample Input

5 3 1 3 4
10 4 9 8 4 2
20 4 10 5 7 4
90 8 10 23 1 2 3 4 5 7
45 8 4 10 44 43 12 9 8 2


Sample Output

1 4 sum:5
8 2 sum:10
10 5 4 sum:19
10 23 1 2 3 4 5 7 sum:55
4 10 12 9 8 2 sum:45


Miguel A. Revilla 2000-01-10

#include <iostream>
#include <vector>
#include <stack>

using namespace std;

class CD{
private:
int value, track;
vector<int> minute;
int sum[30][1500];
stack<int> path;
public:
void initialize(int m, int t);
void readCase();
void computing();
void outResult();
};

void CD::initialize(int m, int t){
value = m;
track = t;
minute.clear();
while(!path.empty()){path.pop();}
}

void CD::readCase(){
int temp;
minute.push_back(0);
for(int i = 1; i <= track; i++){
cin >> temp;
minute.push_back(temp);
}
}

void CD::computing(){
for(int i = 1; i <= track; i++){
for(int j = 0; j <= value; j++){
if(j - minute[i] >= 0){sum[i][j] = max(sum[i - 1][j], sum[i - 1][j - minute[i]] + minute[i]);}
else{sum[i][j] = sum[i - 1][j];}
}
}
int i = track, j = value;

while(sum[i][j]){
if(sum[i][j] == sum[i - 1][j - minute[i]] + minute[i]){
path.push(minute[i]);
j = j - minute[i];
}
i--;
}
}

void CD::outResult(){
while(!path.empty()){
cout << path.top() << ' ';
path.pop();
}
cout << "sum:" << sum[track][value] << endl;
}

int main(){
CD cd;
int m, t;
while(cin >> m >> t){
cd.initialize(m, t);
cd.readCase();
cd.computing();
cd.outResult();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: