您的位置:首页 > 其它

POJ 3292 Semi-prime H-numbers

2013-02-19 20:21 387 查看
Semi-prime H-numbers

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6466 Accepted: 2714
Description

This problem is based on an exercise of David Hilbert, who pedagogically suggested that one study the theory of
4n+1 numbers. Here, we do only a bit of that.

An H-number is a positive number which is one more than a multiple of four: 1, 5, 9, 13, 17, 21,... are the
H-numbers. For this problem we pretend that these are the only numbers. The
H-numbers are closed under multiplication.

As with regular integers, we partition the H-numbers into units,
H-primes, and H-composites. 1 is the only unit. An
H-number h is H-prime if it is not the unit, and is the product of two
H-numbers in only one way: 1 × h. The rest of the numbers are
H-composite.

For examples, the first few H-composites are: 5 × 5 = 25, 5 × 9 = 45, 5 × 13 = 65, 9 × 9 = 81, 5 × 17 = 85.

Your task is to count the number of H-semi-primes. An
H
-semi-prime is an H-number which is the product of exactly two
H-primes. The two H-primes may be equal or different. In the example above, all five numbers are
H-semi-primes. 125 = 5 × 5 × 5 is not an H-semi-prime, because it's the product of three
H-primes.

Input

Each line of input contains an H-number ≤ 1,000,001. The last line of input contains 0 and this line should not be processed.

Output

For each inputted H-number h, print a line stating
h and the number of H-semi-primes between 1 and h inclusive, separated by one space in the format shown in the sample.

Sample Input
21
85
789
0

Sample Output
21 0
85 5
789 62

Source
Waterloo Local Contest, 2006.9.30
一开始一个地方的条件写错了,错了好几次,比如725应该不是,725=25*29; 我只考虑了29是不是,而忽略了25。
#include <stdio.h>
#include <string.h>
#include <math.h>
int res[1000010],status[1000010];
int main()
{
int i,j,n,m,s,t,key;
memset(res,0,sizeof(res));
memset(status,0,sizeof(status));
for(i=5;i<=1000001;i+=4)
{
t=(int)(sqrt((double)i)+0.01);
for(j=5,key=0;j<=t;j+=4)
{
if(i%j==0)
{
if((i/j+3)%4==0)
{
key=1;
if(status[i/j]||status[j])
{
break;
}
}
}
}
if(key==1&&j>t)
{
status[i]=1;
}
}
for(i=5;i<=1000001;i+=4)
{
if(status[i])
{
res[i]=res[i-4]+1;
}else
{
res[i]=res[i-4];
}
}
while(scanf("%d",&n)!=EOF)
{
if(n==0)
{
break;
}
printf("%d %d\n",n,res
);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: