您的位置:首页 > 运维架构

杭电OJ题 1678 Shopaholic 解题报告

2013-01-24 21:32 399 查看

Shopaholic

[align=center]Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1034    Accepted Submission(s): 568

[/align]

[align=left]Problem Description[/align]
Lindsay is a shopaholic. Whenever there is a discount of the kind where you can buy three items and only pay for two, she goes completely mad and feels a need to buy all items in the store. You have given up on curing her for this
disease, but try to limit its effect on her wallet.

You have realized that the stores coming with these offers are quite elective when it comes to which items you get for free; it is always the cheapest ones. As an example, when your friend comes to the counter with seven items, costing 400, 350, 300, 250, 200,
150, and 100 dollars, she will have to pay 1500 dollars. In this case she got a discount of 250 dollars. You realize that if she goes to the counter three times, she might get a bigger discount. E.g. if she goes with the items that costs 400, 300 and 250,
she will get a discount of 250 the first round. The next round she brings the item that costs 150 giving no extra discount, but the third round she takes the last items that costs 350, 200 and 100 giving a discount of an additional 100 dollars, adding up to
a total discount of 350.

Your job is to find the maximum discount Lindsay can get.
 

[align=left]Input[/align]
The first line of input gives the number of test scenarios, 1 <= t <= 20. Each scenario consists of two lines of input. The first gives the number of items Lindsay is buying, 1 <= n <= 20000. The next line gives the prices of these
items, 1 <= pi <= 20000.

 

[align=left]Output[/align]
For each scenario, output one line giving the maximum discount Lindsay can get by selectively choosing which items she brings to the counter at the same time.

 

[align=left]Sample Input[/align]

1
6
400 100 200 350 300 250

 

[align=left]Sample Output[/align]

400

 

————————————————————————————————————

用快排,否则可能会超时,思路:先将数据按从小到大排序,然后从三个开始查找,每次步进为3,直到结束,所有找到的值即为结果最大的counts,贪心法

/****************************
*Name:Shopaholic.c
*Tags:ACM water
*Note:用快排,否则可能会超时,思路:先将数据按从小到大排序,然后从三个开始查找,每次步进为3,直到结束,所有找到的值即为结果最大的counts,贪心法
****************************/

#include <stdio.h>

void quick_sort(int *, int, int);
int process(int *, int, int);

int main()
{
int t, n, pi[20001];
int i, j, counts;
scanf("%d", &t);
while(t--) {
scanf("%d", &n);
for(i = 0; i < n; i++) {
scanf("%d", pi+i);
}
quick_sort(pi, 0, n-1);
i = 2;
counts = 0;
while(i < n) {
counts += pi[i];
i += 3;
}
printf("%d\n", counts);
}
return 0;
}

void quick_sort(int *pi, int i, int j)
{
int x;
if(i < j) {
x = process(pi, i, j);
quick_sort(pi, i, x-1);
quick_sort(pi, x+1, j);
}
}

int process(int *pi, int i, int j)
{
int x;
x = pi[i];
while(i < j) {
while(i < j && pi[j] <= x) {
j--;
}
pi[i] = pi[j];
while(i < j && pi[i] >= x) {
i++;
}
pi[j] = pi[i];
}
pi[i] = x;
return i;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息