您的位置:首页 > 其它

USACO1.1.2 Greedy Gift Givers(贪婪的礼物送礼者)

2013-01-08 11:23 351 查看
A group of NP (2 ≤ NP ≤ 10) uniquely named friends has decided to exchange gifts of money. Each of these friends might or might not give some money to any or all of the other friends. Likewise, each
friend might or might not receive money from any or all of the other friends. Your goal in this problem is to deduce how much more money each person gives than they receive.

The rules for gift-giving are potentially different than you might expect. Each person sets aside a certain amount of money to give and divides this money evenly among all those to whom he or she
is giving a gift. No fractional money is available, so dividing 3 among 2 friends would be 1 each for the friends with 1 left over -- that 1 left over stays in the giver's "account".

In any group of friends, some people are more giving than others (or at least may have more acquaintances) and some people have more money than others.

Given a group of friends, no one of whom has a name longer than 14 characters, the money each person in the group spends on gifts, and a (sub)list of friends to whom each person gives gifts, determine
how much more (or less) each person in the group gives than they receive.

IMPORTANT NOTE

The grader machine is a Linux machine that uses standard Unix conventions: end of line is a single character often known as '\n'. This differs from Windows, which ends lines with two charcters, '\n'
and '\r'. Do not let your program get trapped by this!

PROGRAM NAME: gift1

INPUT FORMAT

Line 1:The single integer, NP
Lines 2..NP+1:
Each line contains the name of a group member
Lines NP+2..end:NP groups of lines organized like this:
The first line in the group tells the person's name who will be giving gifts.
The second line in the group contains two numbers: The initial amount of money (in the range 0..2000) to be divided up into gifts by the giver and then the number of people to whom the giver will
give gifts, NGi (0 ≤ NGi ≤ NP-1).
If NGi is nonzero, each of the next NGi lines lists the the name of a recipient of a gift.

SAMPLE INPUT (file gift1.in)

5
dave
laura
owen
vick
amr
dave
200 3
laura
owen
vick
owen
500 1
dave
amr
150 2
vick
owen
laura
0 2
amr
vick
vick
0 0

OUTPUT FORMAT

The output is NP lines, each with the name of a person followed by a single blank followed by the net gain or loss (final_money_value - initial_money_value) for that person. The names should be printed
in the same order they appear on line 2 of the input.

All gifts are integers. Each person gives the same integer amount of money to each friend to whom any money is given, and gives as much as possible that meets this constraint. Any money not given
is kept by the giver.

SAMPLE OUTPUT (file gift1.out)

dave 302
laura 66
owen -359
vick 141
amr -150


题目大意:在这个问题中,每个人都准备了一些钱来送礼物,而这些钱将会被平均分给那些将收到他的礼物的人,给出每个人将花在送礼上的钱,和将收到他的礼物的人的列表,你要确定每个人送出的礼物比收到的多多少。

解题思路:直接模拟即可,检索姓名时可以使用字符串哈希优化。

以下是我的代码:


/*
USER:xingwen wang
TASK:gift1
LANG:C
*/
#include<stdio.h>
#include<string.h>
int main()
{
freopen("gift1.in","r",stdin);
freopen("gift1.out","w",stdout);
int i,j,k,n,m,money,N,in[11]={0},out[11]={0};
char str[15],name[11][15];
scanf("%d",&n);
for(i=0;i<n;i++)
scanf("%s",name[i]);
for(i=0;i<n;i++)
{
scanf("%s",&str);
for(k=0;k<n;k++)
if(strcmp(name[k],str)==0)
break;
scanf("%d%d",&money,&N);
if(N!=0)
{
out[k]=money-money%N;
m=N;
while(m--)
{
scanf("%s",str);
for(j=0;j<n;j++)
if(strcmp(name[j],str)==0)
{
in[j]=in[j]+out[k]/N;
break;
}
}
}
}
for(i=0;i<n;i++)
printf("%s %d\n",name[i],in[i]-out[i]);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  USACO 字符串 模拟