您的位置:首页 > 其它

USACO Section 3.1 Score Inflation(完全背包)

2012-09-11 10:50 10 查看
原文链接:https://www.geek-share.com/detail/2558331800.html
Score Inflation

The more points students score in our contests, the happier we here at the USACO are. We try to design our contests so that people can score as many points as possible, and would like your assistance.

We have several categories from which problems can be chosen, where a "category" is an unlimited set of contest problems which all require the same amount of time to solve and deserve the same number of points for a correct solution. Your task is write a program which tells the USACO staff how many problems from each category to include in a contest so as to maximize the total number of points in the chosen problems while keeping the total solution time within the length of the contest.

The input includes the length of the contest, M (1 <= M <= 10,000) (don't worry, you won't have to compete in the longer contests until training camp) and N, the number of problem categories, where 1 <= N <= 10,000.

Each of the subsequent N lines contains two integers describing a category: the first integer tells the number of points a problem from that category is worth (1 <= points <= 10000); the second tells the number of minutes a problem from that category takes to solve (1 <= minutes <= 10000).

Your program should determine the number of problems we should take from each category to make the highest-scoring contest solvable within the length of the contest. Remember, the number from any category can be any nonnegative integer (0, one, or many). Calculate the maximum number of possible points.

PROGRAM NAME: inflate

INPUT FORMAT

Line 1: M, N -- contest minutes and number of problem classes
Lines 2-N+1: Two integers: the points and minutes for each class

SAMPLE INPUT (file inflate.in)

300 4
100 60
250 120
120 100
35 20

OUTPUT FORMAT

A single line with the maximum number of points possible given the constraints.

SAMPLE OUTPUT (file inflate.out)

605

分析:裸完全背包

View Code
/*
ID: dizzy_l1
LANG: C++
TASK: inflate
*/
#include<iostream>
#include<cstring>
#include<string>
#include<cstdio>
#define MAXN 10001

using namespace std;

int d[MAXN],cost[MAXN],weight[MAXN];

int main()
{
freopen("inflate.in","r",stdin);
freopen("inflate.out","w",stdout);
int v,n,i,j;
while(scanf("%d%d",&v,&n)==2)
{
memset(d,0,sizeof(d));
for(i=0;i<n;i++)
{
scanf("%d%d",&weight[i],&cost[i]);
}
for(i=0;i<n;i++)
{
for(j=cost[i];j<=v;j++)
{
d[j]=max(d[j],d[j-cost[i]]+weight[i]);
}
}
printf("%d\n",d[v]);
}
return 0;
}

转载于:https://www.cnblogs.com/zhourongqing/archive/2012/09/11/2679827.html

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: