您的位置:首页 > 其它

hdu-1597一道简单的题目主要是注意Tle

2012-08-18 10:24 423 查看


find the nth digit

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 5655 Accepted Submission(s): 1597



Problem Description

假设:

S1 = 1

S2 = 12

S3 = 123

S4 = 1234

.........

S9 = 123456789

S10 = 1234567891

S11 = 12345678912

............

S18 = 123456789123456789

..................

现在我们把所有的串连接起来

S = 1121231234.......123456789123456789112345678912.........

那么你能告诉我在S串中的第N个数字是多少吗?

Input

输入首先是一个数字K,代表有K次询问。

接下来的K行每行有一个整数N(1 <= N < 2^31)。

Output

对于每个N,输出S中第N个对应的数字.

Sample Input

6
1
2
3
4
5
10


Sample Output

1
1
2
1
2
4


Author

8600

Source

HDU 2007-Spring Programming Contest - Warm Up
(1)

Recommend

8600

Statistic | Submit | Discuss | Note

网址:http://acm.hdu.edu.cn/showproblem.php?pid=1597

******************************************************************************************************

******************************************************************************************************

先找出要查找值处于哪个si中,然后再找在si中是9循环的所以%9就行

之前想用for找到i但是TLE了后来才想起来用一元二次方程求根公式

*******************************************************************************************************

*******************************************************************************************************

代码:

#include<stdio.h>
#include <math.h>
int main(){
int i,m,x,t;
scanf("%d",&t);
while(t--){
scanf("%d",&m);
i = ceil((sqrt(1.0+8.0*m)-1)/2.0);
x=m-i*(i-1.0)/2.0;
x=x%9;
if(x==0)x=9;
printf("%d\n",x);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: