您的位置:首页 > 其它

I - An Easy Problem!解题报告(张宇)

2012-04-17 21:54 459 查看
I - An Easy Problem!
Time Limit:1000MS Memory Limit:10000KB 64bit IO Format:%I64d
& %I64u
Submit Status Practice POJ
1152

Description

Have you heard the fact "The base of every normal number system is 10" ? Of course, I am not talking about number systems like Stern Brockot Number System. This problem has nothing to do with this fact but may have some similarity.

You will be given an N based integer number R and you are given the guaranty that R is divisible by (N-1). You will have to print the smallest possible value for N. The range for N is 2 <= N <= 62 and the digit symbols for 62 based number is (0..9 and A..Z
and a..z). Similarly, the digit symbols for 61 based number system is (0..9 and A..Z and a..y) and so on.

Input

Each line in the input will contain an integer (as defined in mathematics) number of any integer base (2..62). You will have to determine what is the smallest possible base of that number for the given conditions. No invalid number will be given as input. The
largest size of the input file will be 32KB.

Output

If number with such condition is not possible output the line "such number is impossible!" For each line of input there will be only a single line of output. The output will always be in decimal number system.

Sample Input

3
5
A


Sample Output

4
6
11


题意: 正如题目所说,一个简单的问题!输入一个2-62进制的数字,即假设这个数字是n进制,则这个数x%(n-1)==0。好吧,既然如此简单,就不废话了。。。。

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
char a[100000];
int main()
{
int i,s,len,max;
bool d;
while(scanf("%s",a)!=EOF)
{
len=strlen(a);
s=0;
max=0;               //max记录所能代表的最小进制数(比如数字里面有B,则这个进制至少也是12吧。。。)
for(i=0;i<len;i++)             //接下来的过程,不要怀疑.经过验证了的
{	//(如果这个n进制的数能取余n-1等于0,则这个数的各个位数相加也要能取余n-1等于0,这样问题变简单咯)[这个很容易证明的,不妨试试]
if (a[i]>='0'&&a[i]<='9')
{
if (a[i]-'0'>max) max=a[i]-'0';
s=s+a[i]-'0';
}
if (a[i]>='a'&&a[i]<='z')
{
if (a[i]-'a'+36>max) max=a[i]-'a'+36;
s=s+a[i]-'a'+36;
}
if (a[i]>='A'&&a[i]<='Z')
{
if (a[i]-'A'+10>max) max=a[i]-'A'+10;
s=s+a[i]-'A'+10;
}
}
d=false;
for(i=2;i<=62;i++)
if (s%(i-1)==0&&max<i) {d=true;break;}
if (d) printf("%d\n",i);
else
printf("such number is impossible!\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: