您的位置:首页 > 其它

POJ 1258 Agri-Net(最小生成树Prim算法)

2012-02-25 21:10 363 查看
Agri-Net

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 25461Accepted: 10033
Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.
The distance between any two farms will not exceed 100,000.
Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.
Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.
Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28

Source

USACO 102
解题报告:今天做了一天的题,找了个简单的最小生成树做做,这个题是最简单的求最小生成树的题,我用的是Prim()做的;
代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int N = 110;
int map

, dis
, visit
;
int n, ans;
void Prim()
{
int i, min, p, k;
memset(dis, 0, sizeof(dis));//初始化
memset(visit, 0, sizeof(visit));
for (i = 1; i <= n; ++i)
{
dis[i] = map[1][i];
}
visit[1] = 1;
ans = 0;
for (k = 1; k < n; ++k) //若所有的点连通,只要算出n -1 条边即可
{
p = 1;
min = 100010;
for (i = 1; i <= n; ++i)
{
if (!visit[i] && min > dis[i])
{
min = dis[i];//选出最小的边
p = i;
}
}
visit[p] = 1;
ans += min;
for (i = 1; i <= n; ++i)
{
if (!visit[i] && dis[i] > map[p][i])//距离的更新
{
dis[i] = map[p][i];
}
}
}
}
int main()
{
int i, j;
while (scanf("%d", &n) != EOF)
{
memset(map, 0, sizeof(map));
for(i = 1 ; i <= n; ++i)
{
for (j = 1; j <= n; ++j)
{
scanf("%d", &map[i][j]);
}
}
Prim();
printf("%d\n", ans);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: