您的位置:首页 > 其它

poj1063 Flip and Shift

2011-11-21 09:25 260 查看
Flip and Shift

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 5669Accepted: 2604
Description

This puzzle consists of a random sequence of m black disks and n white disks on an oval-shaped track, with a turnstile capable of flipping (i.e., reversing) three consecutive disks. In Figure 1, there are 8 black disks and 10 white disks on the track. You may spin the turnstile to flip the three disks in it or shift one position clockwise for each of the disks on the track (Figure 1).



The goal of this puzzle is to gather the disks of the same color in adjacent positions using flips and shifts. (Figure 2)



You are to write a program which decides whether a given sequence can reach a goal or not. If a goal is reachable, then write a message "YES"; otherwise, write a message "NO".
Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each of the next T lines gives a test case. A test case consists of an integer, representing the sum of m and n, and a sequence of m+n 0s and 1s, representing an initial sequence. A 0 denotes a white disk and a 1 denotes a black disk. The sum of m and n is at least 10 and does not exceed 30. There is a space between numbers.
Output

The output should print either "YES" or "NO" for each test case, one per line.
Sample Input

2
18 0 0 1 0 1 1 1 1 0 1 0 0 1 0 0 0 0 1
14 1 1 0 0 1 1 1 0 0 1 1 0 1 0

Sample Output

YES
NO


#include<stdio.h>
#include<cmath>
/*
如果是奇数,那么一定是‘YES’
如果是偶数,则统计在奇数位上和偶数位上白棋的个数,如果他们相差小于2,那么也一定是'YES'
*/
int main()
{
int n;
//    freopen("E:\\c++\\oj\\t.txt","rt",stdin);
scanf("%d",&n);
while(n--)
{
int m,s[101],i;
int ji=0,ou=0;
scanf("%d",&m);
if(m%2)
{
for(i=1;i<=m;i++)
scanf("%d",&s[i]);
printf("YES\n");
}
else
{
for(i=1;i<=m;i++)
{
scanf("%d",&s[i]);
if(!s[i] && i%2)
ji++;
if(!s[i] && !(i%2))
ou++;
}
if((ji-ou)<2 && (ji-ou)>-2)
printf("YES\n");
else
printf("NO\n");
}
}
return 0;
}



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: