您的位置:首页 > 其它

joj 2262: Brackets 最多有多少括号匹配

2011-10-19 23:40 218 查看
We give the following inductive definition of a " regular brackets " sequence:

the empty sequence is a regular brackets sequence,
if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and

if a and b are regular brackets sequences, then ab is a regular brackets sequence.

no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 . . . an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, . . . , im where 1 ≤ i1
< i2 < . . . < im ≤ n, ai1 ai2 . . . aim is a regular brackets sequence. For example, given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing
the word " end " and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6


//

#include<iostream>

#include<cstdio>

#include<cstring>

#include<string>

using namespace std;

int dp[115][115],path[115][115];

char s[115];

void out(int i,int j)

{

if(i>j) return ;

if(i==j)

{

if(s[i]=='['||s[i]==']') cout<<"[]";

else cout<<"()";

return ;

}

if(path[i][j]==-1)

{

cout<<s[i];

out(i+1,j-1);

cout<<s[j];

}

else

{

out(i,path[i][j]);

out(path[i][j]+1,j);

}

}

int main()

{

while(gets(s))

{

if(s[0]=='e') break;

memset(path,0,sizeof(path));

int n=strlen(s);

if(n==0) {cout<<endl;continue;}

for(int i=0;i<=n;i++) dp[i][i]=1,dp[i][i-1]=0;

for(int p=1;p<n;p++)

{

for(int i=0;i+p<n;i++)

{

int j=i+p;

dp[i][j]=(1<<31)-1;

if((s[i]=='('&&s[j]==')')||(s[i]=='['&&s[j]==']'))

{

if(dp[i][j]>dp[i+1][j-1]) dp[i][j]=dp[i+1][j-1],path[i][j]=-1;

}

/* if(s[i]=='('||s[i]=='[')

{

if(dp[i][j]>dp[i+1][j]+1) dp[i][j]=dp[i+1][j]+1,path[i][j]=i;

}

if(s[j]==')'||s[j]==']')

{

if(dp[i][j]>dp[i][j-1]+1) dp[i][j]=dp[i][j-1]+1,path[i][j]=j-1;

}*/ //inclued by the next

for(int k=i;k<j;k++)

{

if(dp[i][j]>dp[i][k]+dp[k+1][j]) dp[i][j]=dp[i][k]+dp[k+1][j],path[i][j]=k;

}

}

}

cout<<n-dp[0][n-1]<<endl;

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐