您的位置:首页 > 其它

POJ 3517 And Then There Was One

2011-10-09 23:33 344 查看
原题地址

http://poj.org/problem?id=3517

And Then There Was One

Time Limit: 5000MSMemory Limit: 65536K
Description

Let’s play a stone removing game.

Initially, n stones are arranged on a circle and numbered 1, …, n clockwise (Figure 1). You are also given two numbers k and m. From this state, remove stones one by one following the rules explained below, until only
one remains. In step 1, remove stone m. In step 2, locate the k-th next stone clockwise from m and remove it. In subsequent steps, start from the slot of the stone removed in the last step, make k hops clockwise on the remaining
stones and remove the one you reach. In other words, skip (k − 1) remaining stones clockwise and remove the next one. Repeat this until only one stone is left and answer its number. For example, the answer for the case n = 8, k =
5, m = 3 is 1, as shown in Figure 1.



Initial state


Step 1


Step 2


Step 3


Step 4


Step 5


Step 6


Step 7


Final state
Figure 1: An example game
Initial state: Eight stones are arranged on a circle.

Step 1: Stone 3 is removed since m = 3.

Step 2: You start from the slot that was occupied by stone 3. You skip four stones 4, 5, 6 and 7 (since k = 5), and remove the next one, which is 8.

Step 3: You skip stones 1, 2, 4 and 5, and thus remove 6. Note that you only count stones that are still on the circle and ignore those already removed. Stone 3 is ignored in this case.

Steps 4–7: You continue until only one stone is left. Notice that in later steps when only a few stones remain, the same stone may be skipped multiple times. For example, stones 1 and 4 are skipped
twice in step 7.

Final State: Finally, only one stone, 1, is on the circle. This is the final state, so the answer is 1.

Input

The input consists of multiple datasets each of which is formatted as follows.

n k m

The last dataset is followed by a line containing three zeros. Numbers in a line are separated by a single space. A dataset satisfies the following conditions.

2 ≤ n ≤ 10000, 1 ≤ k ≤ 10000, 1 ≤ m ≤ n

The number of datasets is less than 100.

Output

For each dataset, output a line containing the stone number left in the final state. No extra characters such as spaces should appear in the output.

Sample Input

8 5 3

100 9999 98

10000 10000 10000

0 0 0


Sample Output

1

93

2019


本程序采用模拟的方式,使用静态链表存储结构,使用数组模拟链表,时间复杂度比较大,代码中要注意使用取遇运算使循环次数大大减少。提交了好几次,总是TLE,加上
%运算后总是出错,那是由于取余运算的结果可能是0,影响正常逻辑,单独考虑这种情况后AC,不过1000+MS,汗.......
下面是我的代码

/**************************************************************************
* Problem: POJ 3517 And Then There Was One
* Copyright 2011 by Yan
* DATE:
* E-Mail: yming0221@gmail.com
************************************************************************/
#include <stdio.h>

int stone[10001];

int main()
{

int i;
int m,n,k;
int tmp;
int cnt;/*用于计数,石头个数*/
int index;
while(1)
{

scanf("%d %d %d",&n,&k,&m);
cnt=n;
m--;/*由于本程序从0开始编号*/

if(n==0) break;
for(i=0; i<n; i++) stone[i]=i+1;
stone[n-1]=0;/*使数组围成环*/

index=m%n;/*保存第m块的位置*/

/*移除第m块石头*/
stone[(m+n-1)%n]=(m+n+1)%n;
cnt--;

while(cnt>0)
{

if(k-1!=cnt)
for(i=0;i<(k-1)%cnt;i++)
{
index=stone[index];
}/*此时指针指向要删除节点的上一个节点*/
else
for(i=0;i<(k-1);i++)
{
index=stone[index];
}/*此时指针指向要删除节点的上一个节点*/
if(cnt==1) printf("%d\n",stone[index]+1);
/*printf("删除%d\n",stone[index]);*/

stone[index]=stone[stone[index]];
cnt--;
}

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: