您的位置:首页 > 其它

数论之求欧拉函数

2011-09-24 09:10 357 查看
简单的求欧拉函数的值,留下来做个模板。。。。。。。。。。

题目:

Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.

Input

There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.

Output

For each test case there should be single line of output answering the question posed above.

Sample Input

7
12
0


Sample Output

6
4


ac代码:

#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;
long long euler(long long y){
int m=(int)sqrt(y+0.5);
int ans=y;
for(int i=2;i<=m;++i){
if(y%i==0){
ans=ans/i*(i-1);
while(y%i==0)
y/=i;
}
}
if(y>1)
ans=ans/y*(y-1);
return ans;
}
int main()
{
long long n;
while(cin>>n&&n){
long long x=euler(n);
cout<<x<<endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: