您的位置:首页 > 其它

hdu 1001 Sum Problem 的解题报告

2011-04-01 19:50 351 查看
链接:http://acm.hdu.edu.cn/showproblem.php?pid=1001

[align=left]Problem Description[/align]
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.

[align=left]Input[/align]
The input will consist of a series of integers n, one integer per line.

[align=left]Output[/align]
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.

[align=left]Sample Input[/align]

1
100

[align=left]Sample Output[/align]

1

5050

View Code

#include<stdio.h>
int main()
{
int a;
int i;
while(scanf("%d",&a)!=EOF)
{
int sum=0;
if(a==1) sum=1;
else
{
for( i=1;i<=a;i++)
{

sum=sum+i;
}
}
printf("%d",sum);
printf("\n\n");

}
return 0;
}

#include<stdio.h>
int main()
{
int n,sum;
//s=N*(N+1)/2
while(scanf("%d",&n)==1 )
{
sum=0;
if( n%2 )
sum=(n+1)/2*n;
else sum=n/2*(n+1);
printf("%d\n\n",sum);
}
return 0;
}


  
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: